CVE-2018-0618
Medium · 5.4CVSS
5.4
EPSS
2.0%
Published
Jul 26, 2018
CISA due date
—
Cloudanix analysis
A flaw in an older email list management tool lets logged-in attackers trick other users' browsers into running harmful code, which could expose private information or allow misuse of the mailing lists.
- Exploitation
- Requires User Interaction
- Attacker needs
- Low Privilege
- Complexity
- Low
- Impact
- Data Tampering
- Component
- Application
- Class
- XSS
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
The vulnerability permits remote authenticated users to inject arbitrary HTML or JavaScript into Mailman web pages through unspecified input vectors, resulting in reflected or stored cross-site scripting that executes in the context of other users' browsers.
Why it matters to the business
Successful exploitation can lead to theft of user session tokens, unauthorized actions on mailing lists, or defacement of administrative interfaces, disrupting email list operations and eroding trust in the service.
How an attack unfolds
An attacker first authenticates to a Mailman instance, then crafts specially formatted input that reaches the vulnerable web interface; when other authenticated or unauthenticated users view the affected pages, the injected script executes in their browsers, allowing cookie theft or further actions within the application.
How to fix it
Upgrade GNU Mailman to a version newer than 2.1.26 that contains the XSS fixes; apply vendor or distribution patches where available; restrict access to administrative interfaces and sanitize all user-supplied content as a defense-in-depth measure.
How to confirm the fix worked
Confirm the installed Mailman version is greater than 2.1.26; review release notes for XSS remediation; perform authenticated web application scanning or manual testing with benign script payloads to verify input sanitization.
Typical attack path
- Obtain a valid Mailman account or credentials
- Submit malicious input containing script or HTML via the vulnerable form or field
- Wait for or lure other users to load the tainted page
- Capture session data or perform actions on behalf of the victim user
How to detect it
Examine web server access logs for unusual query parameters or POST bodies containing script tags, event handlers, or encoded JavaScript; inspect Mailman error or access logs for repeated submissions from the same authenticated user that later appear in rendered pages; search browser histories or proxy logs for unexpected redirects or cookie exfiltration attempts originating from Mailman URLs.
What your security team should do
- Immediately inventory all Mailman deployments and schedule upgrades
- Enable web application firewall rules that block common XSS patterns on Mailman paths
- Review and tighten permissions so only necessary users can post content that renders in the web UI
- Monitor for any new patches or advisories from GNU or distribution maintainers
The record
Cross-site scripting vulnerability in Mailman 2.1.26 and earlier allows remote authenticated attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:8 | mailman | 0 | 1:2.1.18-2+deb8u3 |
| Debian:9 | mailman | 0 | 1:2.1.23-1+deb9u3 |
| Mageia:6 | mailman | 0 | 2.1.27-1.mga6 |
| Red Hat:enterprise_linux:7::server | mailman | 0 | 3:2.1.15-30.el7 |
| Red Hat:enterprise_linux:7::server | mailman-debuginfo | 0 | 3:2.1.15-30.el7 |
| Red Hat:enterprise_linux:7::workstation | mailman | 0 | 3:2.1.15-30.el7 |
| Red Hat:enterprise_linux:7::workstation | mailman-debuginfo | 0 | 3:2.1.15-30.el7 |
| SUSE:Enterprise Storage 4 | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Point of Sale 11 SP3 | mailman | 0 | 2.1.15-9.6.6.1 |
| SUSE:Linux Enterprise Server 11 SP3-LTSS | mailman | 0 | 2.1.15-9.6.6.1 |
| SUSE:Linux Enterprise Server 11 SP3-TERADATA | mailman | 0 | 2.1.15-9.6.6.1 |
| SUSE:Linux Enterprise Server 11 SP4 | mailman | 0 | 2.1.15-9.6.6.1 |
| SUSE:Linux Enterprise Server 12 SP1-LTSS | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Server 12 SP2-BCL | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Server 12 SP2-LTSS | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Server 12 SP3 | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Server 12 SP4 | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Server 12-LTSS | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Server for SAP Applications 11 SP4 | mailman | 0 | 2.1.15-9.6.6.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP1 | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP2 | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | mailman | 0 | 2.1.17-3.3.3 |
| SUSE:OpenStack Cloud 7 | mailman | 0 | 2.1.17-3.3.3 |
| Ubuntu:16.04:LTS | mailman | 0 | 1:2.1.20-1ubuntu0.4 |
| Ubuntu:18.04:LTS | mailman | 0 | 1:2.1.26-1ubuntu0.1 |
Related vulnerabilities
- CVE-2020-15011 GNU Mailman before 2.1.33 allows arbitrary content injection via the Cgi/private.py… Also affects mailman
- CVE-2020-12108 /options/mailman in GNU Mailman before 2.1.31 allows Arbitrary Content Injection. Also affects mailman
- CVE-2018-5950 Cross-site scripting (XSS) vulnerability in the web UI in Mailman before 2.1.26 allows… Also affects mailman
- CVE-2016-6893 Cross-site request forgery (CSRF) vulnerability in the user options page in GNU Mailman… Also affects mailman
- CVE-2021-44227 In GNU Mailman before 2.1.38, a list member or moderator can get a CSRF token and craft… Also affects mailman
- CVE-2021-43331 In GNU Mailman before 2.1.36, a crafted URL to the Cgi/options.py user options page can… Also affects mailman
- CVE-2021-43332 In GNU Mailman before 2.1.36, the CSRF token for the Cgi/admindb.py admindb page contains… Also affects mailman
- CVE-2021-42096 GNU Mailman before 2.1.35 may allow remote Privilege Escalation. Also affects mailman