Cloudanix VulnDB

CVE-2016-6893

High · 8.8

CVSS

8.8

EPSS

1.6%

Published

Sep 2, 2016

CISA due date

—

Cloudanix analysis

Schedule a fix SSVC: Track

A weakness in older mailing list software lets attackers secretly change people's account settings if they visit a malicious link while logged in.

Exploitation
Requires User Interaction
Attacker needs
User Interaction
Complexity
Low
Impact
Privilege Gain
Component
Application
Class
CSRF
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Cross-site request forgery in the user options page permits remote attackers to submit authenticated requests that alter user preferences or credentials without the user's knowledge or interaction beyond visiting a malicious page.

Why it matters to the business

Attackers can hijack mailing list accounts to redirect messages, harvest subscriber data, or send unauthorized content, potentially disrupting communications and exposing sensitive participant information across many organizations that still run older Mailman deployments.

How an attack unfolds

An attacker creates a web page containing a hidden form that targets the Mailman user options endpoint. When an authenticated victim is lured to the page, the browser automatically submits the forged request using the victim's session, allowing the attacker to change account settings or credentials.

How to fix it

Upgrade GNU Mailman to version 2.1.23 or later. Where upgrades are delayed, restrict access to the options page behind additional authentication controls or network segmentation.

How to confirm the fix worked

Verify the installed Mailman version is at least 2.1.23. Confirm that the options page now rejects cross-origin requests lacking proper CSRF protections or referer validation.

Typical attack path

  1. Identify the Mailman user options endpoint and craft a CSRF payload that modifies options or credentials
  2. Host the payload on an attacker-controlled domain or embed it in phishing email/HTML
  3. Lure an authenticated user to visit the malicious page while logged into Mailman
  4. Browser submits the authenticated request, applying attacker-chosen changes

How to detect it

Inspect web server and Mailman logs for POST requests to the options page originating from unexpected referers or lacking session-consistent tokens; correlate with subsequent account changes or bounce patterns.

  • POST requests to /mailman/options/ without expected referer header
  • Unexpected changes to delivery_mode or password fields in user options logs

What your security team should do

  • Prioritize upgrade to Mailman 2.1.23+ on all instances
  • Review and rotate any user accounts that may have been exposed
  • Add web application firewall rules to block suspicious POSTs to the options endpoint
  • Monitor mailing list logs for unexpected option changes

The record

Cross-site request forgery (CSRF) vulnerability in the user options page in GNU Mailman 2.1.x before 2.1.23 allows remote attackers to hijack the authentication of arbitrary users for requests that modify an option, as demonstrated by gaining access to the credentials of a victim's account.

Affected packages

Ecosystem Package Introduced Fixed
Debian:7 mailman 0 1:2.1.15-1+deb7u2
Debian:8 mailman 0 1:2.1.18-2+deb8u1
Mageia:5 mailman 0 2.1.20-3.mga5
Red Hat:enterprise_linux:7::server mailman 0 3:2.1.15-30.el7_9.2
Red Hat:enterprise_linux:7::server mailman-debuginfo 0 3:2.1.15-30.el7_9.2
Red Hat:enterprise_linux:7::workstation mailman 0 3:2.1.15-30.el7_9.2
Red Hat:enterprise_linux:7::workstation mailman-debuginfo 0 3:2.1.15-30.el7_9.2
SUSE:Enterprise Storage 4 mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Point of Sale 11 SP3 mailman 0 2.1.15-9.6.6.1
SUSE:Linux Enterprise Point of Sale 11 SP3 mailman 0 2.1.15-9.6.12.1
SUSE:Linux Enterprise Server 11 SP3-LTSS mailman 0 2.1.15-9.6.6.1
SUSE:Linux Enterprise Server 11 SP3-TERADATA mailman 0 2.1.15-9.6.6.1
SUSE:Linux Enterprise Server 11 SP4 mailman 0 2.1.15-9.6.3.1
SUSE:Linux Enterprise Server 11 SP4 mailman 0 2.1.15-9.6.6.1
SUSE:Linux Enterprise Server 11 SP4-LTSS mailman 0 2.1.15-9.6.12.1
SUSE:Linux Enterprise Server 12 SP1-LTSS mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Server 12 SP2-BCL mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Server 12 SP2-LTSS mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Server 12 SP3 mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Server 12 SP4 mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Server 12-LTSS mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Server for SAP Applications 11 SP4 mailman 0 2.1.15-9.6.3.1
SUSE:Linux Enterprise Server for SAP Applications 11 SP4 mailman 0 2.1.15-9.6.6.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP1 mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Server for SAP Applications 12 SP2 mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Server for SAP Applications 12 SP3 mailman 0 2.1.17-3.3.3
SUSE:Linux Enterprise Server for SAP Applications 12 SP4 mailman 0 2.1.17-3.3.3
SUSE:OpenStack Cloud 7 mailman 0 2.1.17-3.3.3
Ubuntu:14.04:LTS mailman 0 1:2.1.16-2ubuntu0.2
Ubuntu:16.04:LTS mailman 0 1:2.1.20-1ubuntu0.1
openSUSE:Tumbleweed mailman 0 2.1.23-1.2

Related vulnerabilities