CVE-2021-43331
Medium · 6.1CVSS
6.1
EPSS
1.4%
Published
Nov 12, 2021
CISA due date
—
Cloudanix analysis
A flaw in the mailing list tool lets attackers trick users into running harmful code in their browsers simply by clicking a specially made link.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Low
- Impact
- Data Exposure
- Component
- Application
- Class
- XSS
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Cross-site scripting flaw allowing arbitrary JavaScript execution through a crafted URL supplied to the Cgi/options.py user options page.
Why it matters to the business
Attackers can hijack user sessions, steal credentials, or deliver phishing content to users of the mailing list service, potentially leading to account compromise and loss of trust in the system.
How an attack unfolds
An attacker crafts a malicious URL containing JavaScript payload targeting the options page, then tricks a victim into visiting the link; when the page renders, the script executes in the victim's browser context with the site's permissions.
How to fix it
Upgrade GNU Mailman to version 2.1.36 or later; apply vendor patches if available for older supported releases; restrict public access to the options page where feasible until patched.
How to confirm the fix worked
Confirm installed version is 2.1.36 or higher; test the options page with known XSS test payloads to verify input sanitization; review changelog for the fix commit.
Typical attack path
- Identify the exposed Mailman options page endpoint
- Craft URL containing executable JavaScript payload
- Deliver the URL to target users via email or other channels
- Victim visits the URL and triggers script execution
- Script performs actions such as cookie theft or unauthorized requests
How to detect it
Inspect web server access logs for requests to the options.py endpoint containing script tags, event handlers, or unusual encoded JavaScript; correlate with user reports of unexpected behavior after visiting list management pages.
- /mailman/options
- options.py?
- <script
- onerror=
- javascript:
What your security team should do
- Prioritize upgrade to 2.1.36 or newer across all instances
- Implement web application firewall rules to block common XSS patterns targeting Mailman paths
- Educate users to avoid clicking unsolicited links to the mailing list interface
- Monitor web logs for anomalous requests to the options endpoint
The record
In GNU Mailman before 2.1.36, a crafted URL to the Cgi/options.py user options page can execute arbitrary JavaScript for XSS.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:9 | mailman | 0 | 1:2.1.23-1+deb9u8 |
| SUSE:HPE Helion OpenStack 8 | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:Linux Enterprise Server 12 SP2-BCL | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:Linux Enterprise Server 12 SP3-BCL | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:Linux Enterprise Server 12 SP3-LTSS | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:Linux Enterprise Server 12 SP4-LTSS | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:Linux Enterprise Server 12 SP5 | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:OpenStack Cloud 8 | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:OpenStack Cloud 9 | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:OpenStack Cloud Crowbar 8 | mailman | 0 | 2.1.17-3.26.1 |
| SUSE:OpenStack Cloud Crowbar 9 | mailman | 0 | 2.1.17-3.26.1 |
| Ubuntu:18.04:LTS | mailman | 0 | 1:2.1.26-1ubuntu0.5 |
| Ubuntu:20.04:LTS | mailman | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | mailman | 0 | 1:2.1.20-1ubuntu0.6+esm2 |
| Ubuntu:Pro:20.04:LTS | mailman | 0 | 1:2.1.29-1ubuntu3.1+esm1 |
Related vulnerabilities
- CVE-2021-44227 In GNU Mailman before 2.1.38, a list member or moderator can get a CSRF token and craft… Also affects mailman
- CVE-2021-43332 In GNU Mailman before 2.1.36, the CSRF token for the Cgi/admindb.py admindb page contains… Also affects mailman
- CVE-2021-42096 GNU Mailman before 2.1.35 may allow remote Privilege Escalation. Also affects mailman
- CVE-2021-42097 GNU Mailman before 2.1.35 may allow remote Privilege Escalation. Also affects mailman
- CVE-2020-15011 GNU Mailman before 2.1.33 allows arbitrary content injection via the Cgi/private.py… Also affects mailman
- CVE-2020-12108 /options/mailman in GNU Mailman before 2.1.31 allows Arbitrary Content Injection. Also affects mailman
- CVE-2018-0618 Cross-site scripting vulnerability in Mailman 2.1.26 and earlier allows remote… Also affects mailman
- CVE-2018-5950 Cross-site scripting (XSS) vulnerability in the web UI in Mailman before 2.1.26 allows… Also affects mailman