CVE-2020-15011
Medium · 4.3CVSS
4.3
EPSS
1.9%
Published
Jun 24, 2020
CISA due date
—
Cloudanix analysis
A problem in older mailing list software lets attackers slip unwanted content into the private archive login page that visitors see.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Low
- Impact
- Data Tampering
- Component
- Application
- Class
- Improper Input Validation
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
The flaw permits unauthenticated attackers to inject arbitrary HTML or script content into responses served by the private archive login page in Cgi/private.py due to missing input validation.
Why it matters to the business
Organizations running affected mailing list software face risk of injected content that could mislead subscribers, damage trust in official archives, or facilitate phishing without requiring authentication or user interaction beyond visiting the page.
How an attack unfolds
An attacker crafts a malicious request containing injected content to the private archive login endpoint; the server reflects the payload without sanitization, resulting in persistent or reflected content visible to other users who access the login page.
How to fix it
Upgrade GNU Mailman to version 2.1.33 or later on all affected installations; apply vendor or distribution patches for Ubuntu and Debian packages once released.
How to confirm the fix worked
Confirm the Mailman version string in the installed package or source matches 2.1.33 or higher; test the private archive login page with previously exploitable inputs to verify sanitization.
Typical attack path
- Identify a Mailman instance running a version prior to 2.1.33
- Craft and send a request to /cgi-bin/private.py containing injection payload in login-related parameters
- Observe reflected or stored arbitrary content in the archive login page served to other visitors
- Leverage injected content for phishing, credential harvesting, or further social engineering
How to detect it
Examine web server access logs for requests to private.py containing suspicious parameters or encoded payloads; monitor for unexpected HTML or script content appearing in rendered login pages.
What your security team should do
- Prioritize upgrade of all GNU Mailman instances to 2.1.33+ within normal change windows
- Review public archive and private archive access logs for unusual login page requests
- Communicate the upgrade requirement to system owners responsible for mailing list infrastructure
The record
GNU Mailman before 2.1.33 allows arbitrary content injection via the Cgi/private.py private archive login page.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:10 | mailman | 0 | 1:2.1.29-1+deb10u2 |
| Debian:8 | mailman | 0 | 1:2.1.18-2+deb8u7 |
| Debian:9 | mailman | 0 | 1:2.1.23-1+deb9u6 |
| Mageia:7 | mailman | 0 | 2.1.33-1.mga7 |
| Red Hat:enterprise_linux:8::appstream | mailman | 0 | 3:2.1.29-11.module+el8.4.0+8277+5e2c6e6e |
| Red Hat:enterprise_linux:8::appstream | mailman-debuginfo | 0 | 3:2.1.29-11.module+el8.4.0+8277+5e2c6e6e |
| Red Hat:enterprise_linux:8::appstream | mailman-debugsource | 0 | 3:2.1.29-11.module+el8.4.0+8277+5e2c6e6e |
| Rocky Linux:8 | mailman | 0 | 3:2.1.29-11.module+el8.4.0+539+54f8785b |
| SUSE:Enterprise Storage 5 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:HPE Helion OpenStack 8 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Point of Sale 11 SP3 | mailman | 0 | 2.1.15-9.6.26.1 |
| SUSE:Linux Enterprise Server 11 SP4-LTSS | mailman | 0 | 2.1.15-9.6.26.1 |
| SUSE:Linux Enterprise Server 12 SP2-BCL | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Server 12 SP2-LTSS | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Server 12 SP3-BCL | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Server 12 SP3-LTSS | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Server 12 SP4-LTSS | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Server 12 SP5 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP2 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:OpenStack Cloud 7 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:OpenStack Cloud 8 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:OpenStack Cloud 9 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:OpenStack Cloud Crowbar 8 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:OpenStack Cloud Crowbar 9 | mailman | 0 | 2.1.17-3.23.1 |
| SUSE:Package Hub 15 SP2 | mailman | 0 | 2.1.34-bp152.7.3.1 |
| Ubuntu:16.04:LTS | mailman | 0 | 1:2.1.20-1ubuntu0.6 |
| Ubuntu:18.04:LTS | mailman | 0 | 1:2.1.26-1ubuntu0.3 |
| Ubuntu:20.04:LTS | mailman | 0 | 1:2.1.29-1ubuntu3.1 |
| openSUSE:Leap 15.2 | mailman | 0 | 2.1.34-lp152.7.3.1 |
Related vulnerabilities
- CVE-2021-42096 GNU Mailman before 2.1.35 may allow remote Privilege Escalation. Also affects mailman
- CVE-2021-42097 GNU Mailman before 2.1.35 may allow remote Privilege Escalation. Also affects mailman
- CVE-2020-12108 /options/mailman in GNU Mailman before 2.1.31 allows Arbitrary Content Injection. Also affects mailman
- CVE-2018-0618 Cross-site scripting vulnerability in Mailman 2.1.26 and earlier allows remote… Also affects mailman
- CVE-2018-5950 Cross-site scripting (XSS) vulnerability in the web UI in Mailman before 2.1.26 allows… Also affects mailman
- CVE-2016-6893 Cross-site request forgery (CSRF) vulnerability in the user options page in GNU Mailman… Also affects mailman
- CVE-2021-44227 In GNU Mailman before 2.1.38, a list member or moderator can get a CSRF token and craft… Also affects mailman
- CVE-2021-43331 In GNU Mailman before 2.1.36, a crafted URL to the Cgi/options.py user options page can… Also affects mailman