CVE-2020-12108
Medium · 6.5CVSS
6.5
EPSS
2.7%
Published
May 6, 2020
CISA due date
—
Cloudanix analysis
An older version of a popular email list tool lets outsiders slip unwanted text or links into the messages it sends out.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Low
- Impact
- Data Tampering
- Component
- Application
- Class
- Improper Input Validation
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
The flaw permits unauthenticated injection of arbitrary content through the /options/mailman endpoint due to missing input validation, allowing an attacker to control message bodies or web responses served by the mailing list software.
Why it matters to the business
Organizations running mailing lists on affected versions risk distribution of malicious or misleading content to subscribers, potential brand damage, loss of trust, and increased support workload; the issue affects widely used open-source list software present in many Linux distributions.
How an attack unfolds
An attacker crafts a specially formatted request to the /options/mailman URL path; because input sanitization is absent, the injected content is stored and later rendered or delivered in list messages or administrative pages without further checks.
How to fix it
Upgrade GNU Mailman to version 2.1.31 or later on all affected systems; where immediate patching is not possible, restrict direct access to the /options/mailman path via web server configuration or WAF rules until the update can be applied.
How to confirm the fix worked
Confirm the installed Mailman version is 2.1.31 or newer; test that requests to /options/mailman containing HTML or script content are rejected or properly escaped; review release notes and changelog entries for the 2.1.31 fix.
Typical attack path
- Identify a publicly reachable GNU Mailman installation running a version prior to 2.1.31
- Submit a crafted HTTP request containing attacker-controlled content to the /options/mailman endpoint
- Observe that the injected content is accepted and subsequently included in outgoing list messages or displayed pages
- Leverage the injected content for phishing, defacement, or further social-engineering campaigns against subscribers
How to detect it
Review web server access logs for repeated or anomalous requests to paths containing /options/mailman; inspect Mailman log files for unexpected content appearing in list archives or message bodies; correlate timestamps of such requests with message delivery events.
- /options/mailman
- mailman.*options
What your security team should do
- Prioritize upgrade of all GNU Mailman instances to 2.1.31 or later within the next maintenance window
- Add temporary network or application-layer controls blocking direct access to /options/mailman for untrusted sources
- Scan package repositories and container images for any remaining vulnerable Mailman versions
- Monitor subscriber reports for unexpected content in list messages as an interim detection measure
The record
/options/mailman in GNU Mailman before 2.1.31 allows Arbitrary Content Injection.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:10 | mailman | 0 | 1:2.1.29-1+deb10u2 |
| Debian:8 | mailman | 0 | 1:2.1.18-2+deb8u6 |
| Debian:9 | mailman | 0 | 1:2.1.23-1+deb9u6 |
| Mageia:7 | mailman | 0 | 2.1.33-1.mga7 |
| Red Hat:enterprise_linux:8::appstream | mailman | 0 | 3:2.1.29-11.module+el8.4.0+8277+5e2c6e6e |
| Red Hat:enterprise_linux:8::appstream | mailman-debuginfo | 0 | 3:2.1.29-11.module+el8.4.0+8277+5e2c6e6e |
| Red Hat:enterprise_linux:8::appstream | mailman-debugsource | 0 | 3:2.1.29-11.module+el8.4.0+8277+5e2c6e6e |
| Rocky Linux:8 | mailman | 0 | 3:2.1.29-11.module+el8.4.0+539+54f8785b |
| SUSE:Enterprise Storage 5 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:HPE Helion OpenStack 8 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server 12 SP1-LTSS | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server 12 SP2-BCL | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server 12 SP2-LTSS | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server 12 SP3-BCL | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server 12 SP3-LTSS | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server 12 SP4 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server 12 SP5 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP1 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP2 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:OpenStack Cloud 7 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:OpenStack Cloud 8 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:OpenStack Cloud Crowbar 8 | mailman | 0 | 2.1.17-3.20.1 |
| SUSE:Package Hub 15 SP1 | mailman | 0 | 2.1.29-bp151.5.9.1 |
| SUSE:Package Hub 15 SP2 | mailman | 0 | 2.1.34-bp152.7.3.1 |
| Ubuntu:16.04:LTS | mailman | 0 | 1:2.1.20-1ubuntu0.5 |
| Ubuntu:18.04:LTS | mailman | 0 | 1:2.1.26-1ubuntu0.2 |
| Ubuntu:20.04:LTS | mailman | 0 | 1:2.1.29-1ubuntu3.1 |
| openSUSE:Leap 15.1 | mailman | 0 | 2.1.29-lp151.3.11.1 |
| openSUSE:Leap 15.2 | mailman | 0 | 2.1.34-lp152.7.3.1 |
Related vulnerabilities
- CVE-2021-42096 GNU Mailman before 2.1.35 may allow remote Privilege Escalation. Also affects mailman
- CVE-2021-42097 GNU Mailman before 2.1.35 may allow remote Privilege Escalation. Also affects mailman
- CVE-2020-15011 GNU Mailman before 2.1.33 allows arbitrary content injection via the Cgi/private.py… Also affects mailman
- CVE-2018-0618 Cross-site scripting vulnerability in Mailman 2.1.26 and earlier allows remote… Also affects mailman
- CVE-2018-5950 Cross-site scripting (XSS) vulnerability in the web UI in Mailman before 2.1.26 allows… Also affects mailman
- CVE-2016-6893 Cross-site request forgery (CSRF) vulnerability in the user options page in GNU Mailman… Also affects mailman
- CVE-2021-44227 In GNU Mailman before 2.1.38, a list member or moderator can get a CSRF token and craft… Also affects mailman
- CVE-2021-43331 In GNU Mailman before 2.1.36, a crafted URL to the Cgi/options.py user options page can… Also affects mailman