CVE-2025-27836
NoneCVSS
—
EPSS
0.6%
Published
Mar 25, 2025
CISA due date
—
Cloudanix analysis
Document processing software contains a flaw that could let attackers take control of a computer by opening a specially made file, so install the available software update right away.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Remote Code Execution
- Component
- Library
- Class
- Buffer Overflow
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Buffer overflow in the Print buffer of the BJ10V device in contrib/japanese/gdev10v.c allows memory corruption during processing of crafted input in Ghostscript before 10.05.0.
Why it matters to the business
Systems handling untrusted documents on the affected Red Hat appliance face risk of remote code execution, potentially leading to full system compromise, data loss, or unauthorized access; prevalence in document workflows amplifies operational disruption.
How an attack unfolds
An attacker supplies a specially crafted file that triggers the buffer overflow in the BJ10V device when Ghostscript processes it, enabling arbitrary code execution on the target system.
How to fix it
Upgrade Ghostscript to 10.05.0 or later; for rhvm-appliance update to version 2:4.2-20190129.0.el7.
How to confirm the fix worked
Confirm Ghostscript version meets or exceeds 10.05.0 and verify rhvm-appliance package is updated to 2:4.2-20190129.0.el7; test processing of sample inputs for absence of overflow conditions.
Typical attack path
- Locate systems running vulnerable Ghostscript on affected Red Hat appliance
- Craft malicious input targeting the BJ10V device buffer
- Deliver the file to a document processing workflow
- Trigger Ghostscript processing with the BJ10V device
- Exploit overflow to execute attacker-controlled code
How to detect it
Review system and application logs for Ghostscript crashes or unexpected BJ10V device activity during file processing; inspect process execution patterns for anomalies around document handling.
What your security team should do
- Apply the fixed package version to rhvm-appliance without delay given the publication age
- Inventory all Ghostscript deployments and restrict untrusted file processing until patched
- Monitor EPSS trend and re-evaluate if exploit maturity increases
The record
An issue was discovered in Artifex Ghostscript before 10.05.0. The BJ10V device has a Print buffer overflow in contrib/japanese/gdev10v.c.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Alpine:v3.18 | ghostscript | 0 | 10.05.0 |
| Alpine:v3.19 | ghostscript | 0 | 10.05.0 |
| Alpine:v3.20 | ghostscript | 0 | 10.05.0 |
| Alpine:v3.21 | ghostscript | 0 | 10.05.0 |
| Alpine:v3.22 | ghostscript | 0 | 10.05.0 |
| Debian:11 | ghostscript | 0 | No fix |
| Debian:11 | ghostscript | 0 | 9.53.3~dfsg-7+deb11u10 |
| Debian:12 | ghostscript | 0 | 10.0.0~dfsg-11+deb12u7 |
| Debian:13 | ghostscript | 0 | 10.05.0~dfsg-1 |
| Debian:14 | ghostscript | 0 | 10.05.0~dfsg-1 |
| Mageia:9 | ghostscript | 0 | 10.05.0-1.mga9 |
| SUSE:Enterprise Storage 7.1 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server 12 SP5-LTSS | ghostscript | 0 | 9.52-23.89.1 |
| SUSE:Linux Enterprise Server 15 SP3-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server 15 SP4-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server 15 SP5-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | ghostscript | 0 | 9.52-23.89.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Manager Proxy 4.3 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Manager Server 4.3 | ghostscript | 0 | 9.52-150000.203.1 |
| openSUSE:Leap 15.6 | ghostscript | 0 | 9.52-150000.203.1 |
| openSUSE:Tumbleweed | ghostscript | 0 | 10.05.0-1.1 |
Related vulnerabilities
- CVE-2025-27835 An issue was discovered in Artifex Ghostscript before 10.05.0. Also affects ghostscript
- CVE-2025-27837 An issue was discovered in Artifex Ghostscript before 10.05.0. Also affects ghostscript
- CVE-2025-27832 An issue was discovered in Artifex Ghostscript before 10.05.0. Also affects ghostscript
- CVE-2024-46956 An issue was discovered in psi/zfile.c in Artifex Ghostscript before 10.04.0. Also affects ghostscript
- CVE-2024-46955 An issue was discovered in psi/zcolor.c in Artifex Ghostscript before 10.04.0. Also affects ghostscript
- CVE-2024-46953 An issue was discovered in base/gsdevice.c in Artifex Ghostscript before 10.04.0. Also affects ghostscript
- CVE-2024-46954 An issue was discovered in decode_utf8 in base/gp_utf8.c in Artifex Ghostscript before… Also affects ghostscript
- CVE-2024-46952 An issue was discovered in pdf/pdf_xref.c in Artifex Ghostscript before 10.04.0. Also affects ghostscript