CVE-2025-27835
NoneCVSS
—
EPSS
0.3%
Published
Mar 25, 2025
CISA due date
—
Cloudanix analysis
A flaw in document processing software could let attackers crash systems or run harmful code by sending specially crafted files.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Moderate
- Impact
- Full Compromise
- Component
- Library
- Class
- Buffer Overflow
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
A buffer overflow occurs when converting glyphs to Unicode in psi/zbfont.c of Ghostscript before 10.05.0, enabling memory corruption.
Why it matters to the business
Organizations running the listed Red Hat .NET packages on RHEL 7 face potential service disruption or compromise in document processing workflows until upgraded, with low immediate risk given minimal exploit activity and no ransomware usage.
How an attack unfolds
An attacker supplies a crafted input triggering the glyph-to-Unicode conversion path in vulnerable Ghostscript instances bundled or depended upon by the affected packages, aiming to corrupt memory for code execution or denial of service.
How to fix it
Upgrade each affected package to its listed fixed version, for example rh-dotnet21 to 0:2.1-7.el7, rh-dotnet22 to 0:2.2-3.el7, and similarly for all other listed dotnetcore and dotnet packages.
How to confirm the fix worked
Use yum or dnf to confirm installed versions match the fixed releases provided, and verify Ghostscript reports version 10.05.0 or later where directly accessible.
Typical attack path
- Locate systems with vulnerable Red Hat dotnet packages on RHEL 7
- Prepare malicious document or font data exploiting the buffer overflow
- Cause the target application to process the input via Ghostscript
- Trigger memory corruption leading to crash or code execution
How to detect it
Review application and system logs for Ghostscript crashes or errors during font or glyph handling on servers running the affected packages; inspect for unexpected process terminations after document processing.
What your security team should do
- Apply the exact fixed package versions across all RHEL 7 dotnet installations without delay
- Audit .NET applications for dependencies that invoke Ghostscript
- Monitor EPSS trend and re-evaluate if exploit maturity increases
The record
An issue was discovered in Artifex Ghostscript before 10.05.0. A buffer overflow occurs when converting glyphs to Unicode in psi/zbfont.c.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Alpine:v3.18 | ghostscript | 0 | 10.05.0 |
| Alpine:v3.19 | ghostscript | 0 | 10.05.0 |
| Alpine:v3.20 | ghostscript | 0 | 10.05.0 |
| Alpine:v3.21 | ghostscript | 0 | 10.05.0 |
| Alpine:v3.22 | ghostscript | 0 | 10.05.0 |
| Debian:11 | ghostscript | 0 | No fix |
| Debian:11 | ghostscript | 0 | 9.53.3~dfsg-7+deb11u10 |
| Debian:12 | ghostscript | 0 | 10.0.0~dfsg-11+deb12u7 |
| Debian:13 | ghostscript | 0 | 10.05.0~dfsg-1 |
| Debian:14 | ghostscript | 0 | 10.05.0~dfsg-1 |
| Mageia:9 | ghostscript | 0 | 10.05.0-1.mga9 |
| SUSE:Enterprise Storage 7.1 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server 12 SP5-LTSS | ghostscript | 0 | 9.52-23.89.1 |
| SUSE:Linux Enterprise Server 15 SP3-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server 15 SP4-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server 15 SP5-LTSS | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | ghostscript | 0 | 9.52-23.89.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Manager Proxy 4.3 | ghostscript | 0 | 9.52-150000.203.1 |
| SUSE:Manager Server 4.3 | ghostscript | 0 | 9.52-150000.203.1 |
| openSUSE:Leap 15.6 | ghostscript | 0 | 9.52-150000.203.1 |
| openSUSE:Tumbleweed | ghostscript | 0 | 10.05.0-1.1 |
Related vulnerabilities
- CVE-2025-27836 An issue was discovered in Artifex Ghostscript before 10.05.0. Also affects ghostscript
- CVE-2025-27837 An issue was discovered in Artifex Ghostscript before 10.05.0. Also affects ghostscript
- CVE-2025-27832 An issue was discovered in Artifex Ghostscript before 10.05.0. Also affects ghostscript
- CVE-2024-46956 An issue was discovered in psi/zfile.c in Artifex Ghostscript before 10.04.0. Also affects ghostscript
- CVE-2024-46955 An issue was discovered in psi/zcolor.c in Artifex Ghostscript before 10.04.0. Also affects ghostscript
- CVE-2024-46953 An issue was discovered in base/gsdevice.c in Artifex Ghostscript before 10.04.0. Also affects ghostscript
- CVE-2024-46954 An issue was discovered in decode_utf8 in base/gp_utf8.c in Artifex Ghostscript before… Also affects ghostscript
- CVE-2024-46952 An issue was discovered in pdf/pdf_xref.c in Artifex Ghostscript before 10.04.0. Also affects ghostscript