Cloudanix VulnDB

CVE-2025-27832

None

CVSS

—

EPSS

0.8%

Published

Mar 25, 2025

CISA due date

—

Cloudanix analysis

Monitor only SSVC: Track

A bug in document handling software used by Red Hat Satellite systems could let attackers crash services or run harmful code, so apply the available software updates right away.

Exploitation
Remote Unauthenticated
Attacker needs
None
Complexity
Moderate
Impact
Remote Code Execution
Component
Library
Class
Buffer Overflow
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Buffer overflow in the NPDL device compression handling within contrib/japanese/gdevnpdl.c allows memory corruption during PostScript or PDF processing.

Why it matters to the business

Organizations using affected Red Hat Satellite versions risk service disruptions or remote code execution in document rendering workflows, increasing operational downtime and potential compromise of content management systems.

How an attack unfolds

An attacker supplies a specially crafted input file that invokes the NPDL device, overflowing the compression buffer to corrupt memory and potentially execute arbitrary code or cause denial of service.

How to fix it

Upgrade all affected packages to the specified fixed versions including satellite 0:6.5.3.2-1.el7sat, satellite-capsule 0:6.5.3.2-1.el7sat, candlepin 0:2.5.22-1.el7sat and equivalent satellite-cli, satellite-common, satellite-debug-tools updates; verify Ghostscript reaches at least 10.05.0.

How to confirm the fix worked

Confirm installed package versions match or exceed the fixed releases listed for each Red Hat Satellite component and test Ghostscript with sample NPDL inputs to ensure no overflow occurs.

Typical attack path

  1. Identify systems running vulnerable Ghostscript versions bundled in Red Hat Satellite
  2. Craft malicious PostScript/PDF targeting the NPDL device
  3. Deliver the file through document processing or print workflows
  4. Trigger buffer overflow to achieve memory corruption or code execution

How to detect it

Search system and application logs for Ghostscript invocations with NPDL device flags, unexpected crashes during PDF/PostScript jobs, or error messages referencing gdevnpdl.c; monitor process execution for unusual Ghostscript child processes handling Japanese or compression-related inputs.

What your security team should do

  • Prioritize patching all listed Satellite packages to the exact fixed versions within the next maintenance window
  • Restrict untrusted document processing jobs that invoke Ghostscript devices
  • Review logging for any prior Ghostscript crashes involving NPDL or Japanese output paths

The record

An issue was discovered in Artifex Ghostscript before 10.05.0. The NPDL device has a Compression buffer overflow for contrib/japanese/gdevnpdl.c.

Affected packages

Ecosystem Package Introduced Fixed
AlmaLinux:10 ghostscript 0 10.02.1-16.el10_0
AlmaLinux:10 ghostscript-doc 0 10.02.1-16.el10_0
AlmaLinux:10 ghostscript-tools-dvipdf 0 10.02.1-16.el10_0
AlmaLinux:10 ghostscript-tools-fonts 0 10.02.1-16.el10_0
AlmaLinux:10 ghostscript-tools-printing 0 10.02.1-16.el10_0
AlmaLinux:10 libgs 0 10.02.1-16.el10_0
AlmaLinux:10 libgs-devel 0 10.02.1-16.el10_0
AlmaLinux:8 ghostscript 0 9.27-17.el8_10
AlmaLinux:8 ghostscript-doc 0 9.27-17.el8_10
AlmaLinux:8 ghostscript-tools-dvipdf 0 9.27-17.el8_10
AlmaLinux:8 ghostscript-tools-fonts 0 9.27-17.el8_10
AlmaLinux:8 ghostscript-tools-printing 0 9.27-17.el8_10
AlmaLinux:8 ghostscript-x11 0 9.27-17.el8_10
AlmaLinux:8 libgs 0 9.27-17.el8_10
AlmaLinux:8 libgs-devel 0 9.27-17.el8_10
AlmaLinux:9 ghostscript 0 9.54.0-19.el9_6
AlmaLinux:9 ghostscript-doc 0 9.54.0-19.el9_6
AlmaLinux:9 ghostscript-tools-dvipdf 0 9.54.0-19.el9_6
AlmaLinux:9 ghostscript-tools-fonts 0 9.54.0-19.el9_6
AlmaLinux:9 ghostscript-tools-printing 0 9.54.0-19.el9_6
AlmaLinux:9 ghostscript-x11 0 9.54.0-19.el9_6
AlmaLinux:9 libgs 0 9.54.0-19.el9_6
AlmaLinux:9 libgs-devel 0 9.54.0-19.el9_6
Alpine:v3.18 ghostscript 0 10.05.0
Alpine:v3.19 ghostscript 0 10.05.0
Alpine:v3.20 ghostscript 0 10.05.0
Alpine:v3.21 ghostscript 0 10.05.0
Alpine:v3.22 ghostscript 0 10.05.0
Debian:11 ghostscript 0 No fix
Debian:11 ghostscript 0 9.53.3~dfsg-7+deb11u10
Debian:12 ghostscript 0 10.0.0~dfsg-11+deb12u7
Debian:13 ghostscript 0 10.05.0~dfsg-1
Debian:14 ghostscript 0 10.05.0~dfsg-1
Mageia:9 ghostscript 0 10.05.0-1.mga9
SUSE:Enterprise Storage 7.1 ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise Module for Basesystem 15 SP6 ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise Server 12 SP5-LTSS ghostscript 0 9.52-23.89.1
SUSE:Linux Enterprise Server 15 SP3-LTSS ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise Server 15 SP4-LTSS ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise Server 15 SP5-LTSS ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 ghostscript 0 9.52-23.89.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP3 ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP4 ghostscript 0 9.52-150000.203.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP5 ghostscript 0 9.52-150000.203.1
SUSE:Manager Proxy 4.3 ghostscript 0 9.52-150000.203.1
SUSE:Manager Server 4.3 ghostscript 0 9.52-150000.203.1
openSUSE:Leap 15.6 ghostscript 0 9.52-150000.203.1
openSUSE:Tumbleweed ghostscript 0 10.05.0-1.1

Related vulnerabilities