CVE-2016-5360
High · 7.5CVSS
7.5
EPSS
42.8%
Published
Jun 30, 2016
CISA due date
—
Cloudanix analysis
An old version of the HAProxy load balancer can crash when handling certain blocked requests, potentially taking websites or services offline.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Application
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
A reqdeny rule in HAProxy 1.6.x before 1.6.6 triggers access to uninitialized memory, resulting in a crash or undefined behavior.
Why it matters to the business
Service outages from crashes that interrupt load-balanced traffic, with potential for broader impact depending on deployment.
How an attack unfolds
An unauthenticated remote attacker sends HTTP requests crafted to match a reqdeny rule, causing the server to dereference uninitialized memory and either crash or exhibit other undefined behavior.
How to fix it
Upgrade HAProxy to version 1.6.6 or later; apply vendor patches for affected distributions such as Ubuntu.
How to confirm the fix worked
Confirm the running HAProxy binary reports version 1.6.6 or newer; test that reqdeny rules no longer trigger crashes under load.
Typical attack path
- Identify a HAProxy instance running version 1.6.x before 1.6.6 that uses reqdeny rules
- Craft and send HTTP requests that trigger the deny condition
- Observe crash or memory corruption side effects
How to detect it
Search load-balancer and system logs for unexpected HAProxy process crashes or segmentation faults around the time of request processing; correlate with traffic that would match deny rules.
What your security team should do
- Prioritize upgrade of all HAProxy 1.6.x instances to 1.6.6+
- Review configurations for reqdeny usage and replace with safer alternatives where possible
- Monitor for service restarts or crashes in load-balancer logs
The record
HAproxy 1.6.x before 1.6.6, when a deny comes from a reqdeny rule, allows remote attackers to cause a denial of service (uninitialized memory access and crash) or possibly have unspecified other impact via unknown vectors.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | haproxy | 0 | 1.6.5-2 |
| Debian:12 | haproxy | 0 | 1.6.5-2 |
| Debian:13 | haproxy | 0 | 1.6.5-2 |
| Debian:14 | haproxy | 0 | 1.6.5-2 |
| Ubuntu:14.04:LTS | haproxy | 0 | 1.4.24-2ubuntu0.4 |
| Ubuntu:16.04:LTS | haproxy | 0 | 1.6.3-1ubuntu0.1 |
Related vulnerabilities
- CVE-2024-49214 QUIC in HAProxy 3.1.x before 3.1-dev7, 3.0.x before 3.0.5, and 2.9.x before 2.9.11 allows… Also affects haproxy
- CVE-2023-0836 An information leak vulnerability was discovered in HAProxy 2.1, 2.2 before 2.2.27, 2.3… Also affects haproxy
- CVE-2023-0056 An uncontrolled resource consumption vulnerability was discovered in HAProxy which could… Also affects haproxy
- CVE-2024-53008 Inconsistent interpretation of HTTP requests ('HTTP Request/Response Smuggling') issue… Also affects haproxy
- CVE-2024-45506 HAProxy 2.9.x before 2.9.10, 3.0.x before 3.0.4, and 3.1.x through 3.1-dev6 allows a… Also affects haproxy
- CVE-2026-112108 A vulnerability was determined in ztxz16 fastllm up to 0.1.8.2. CWE-119
- CVE-2026-112073 A vulnerability was identified in Tencent ncnn up to 44b02dabdcf97499281a4692ebd65bad73dc… CWE-119
- CVE-2026-90831 A vulnerability was detected in GNU Binutils 2.47. CWE-119