CVE-2014-9093
NoneCVSS
—
EPSS
4.1%
Published
Nov 26, 2014
CISA due date
—
Cloudanix analysis
Older versions of document software can crash or allow harmful code to run when a user opens a specially crafted RTF file.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Remote Code Execution
- Component
- Application
- Class
- Improper Input Validation
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Invalid write operation during RTF file parsing in LibreOffice allows memory corruption that can lead to application crash or arbitrary code execution.
Why it matters to the business
Users opening crafted RTF documents risk system crashes that interrupt productivity and potential compromise of affected workstations, especially in environments still running versions prior to 4.3.5.
How an attack unfolds
An attacker creates a specially malformed RTF file and delivers it through email or a download link; when the recipient opens the file in a vulnerable LibreOffice version the parser performs an invalid memory write that may crash the application or allow code execution.
How to fix it
Upgrade LibreOffice to version 4.3.5 or newer on all affected systems; apply vendor updates for Fedora, Ubuntu, and Debian packages as they become available.
How to confirm the fix worked
Verify installed LibreOffice version is 4.3.5 or later; attempt to open known-good RTF files and confirm no crashes occur; review package manager output for successful upgrade.
Typical attack path
- Craft a malicious RTF file containing malformed control structures
- Distribute the file via email attachment or web download
- Victim opens the document using an affected LibreOffice release
- Parser triggers invalid write leading to crash or code execution
How to detect it
Search application and system logs for LibreOffice crashes or segmentation faults immediately following RTF file access; review recent file-open events for suspicious RTF documents.
What your security team should do
- Prioritize patching LibreOffice installations to 4.3.5+ across the environment
- Configure application allow-listing or sandboxing for document viewers
- Educate users to avoid opening RTF files from untrusted sources
- Monitor for new package updates in Fedora, Ubuntu, and Debian repositories
The record
LibreOffice before 4.3.5 allows remote attackers to cause a denial of service (invalid write operation and crash) and possibly execute arbitrary code via a crafted RTF file.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | libreoffice | 0 | 1:4.3.3-2 |
| Debian:12 | libreoffice | 0 | 1:4.3.3-2 |
| Debian:13 | libreoffice | 0 | 1:4.3.3-2 |
| Debian:7 | libreoffice | 0 | 1:3.5.4+dfsg2-0+deb7u3 |
| SUSE:Linux Enterprise Desktop 11 SP4 | google-carlito-fonts | 0 | 1.1.03.beta1-2.1 |
| SUSE:Linux Enterprise Desktop 11 SP4 | hyphen | 0 | 2.8.8-2.1 |
| SUSE:Linux Enterprise Desktop 11 SP4 | libreoffice | 0 | 5.0.4.2-23.1 |
| SUSE:Linux Enterprise Desktop 11 SP4 | libreoffice-share-linker | 0 | 1-2.1 |
| SUSE:Linux Enterprise Desktop 11 SP4 | libreoffice-voikko | 0 | 4.1-2.26 |
| SUSE:Linux Enterprise Desktop 11 SP4 | libvoikko | 0 | 3.7.1-5.2 |
| SUSE:Linux Enterprise Desktop 11 SP4 | myspell-dictionaries | 0 | 20150827-23.1 |
| SUSE:Linux Enterprise Desktop 11 SP4 | mythes | 0 | 1.2.4-2.1 |
| SUSE:Linux Enterprise Desktop 11 SP4 | python-importlib | 0 | 1.0.2-0.8.1 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | google-carlito-fonts | 0 | 1.1.03.beta1-2.1 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | hyphen | 0 | 2.8.8-2.1 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | libreoffice | 0 | 5.0.4.2-23.1 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | libreoffice-share-linker | 0 | 1-2.1 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | libreoffice-voikko | 0 | 4.1-2.26 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | libvoikko | 0 | 3.7.1-5.2 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | myspell-dictionaries | 0 | 20150827-23.1 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | mythes | 0 | 1.2.4-2.1 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | python-importlib | 0 | 1.0.2-0.8.1 |
| Ubuntu:14.04:LTS | libreoffice | 0 | 1:4.2.8-0ubuntu2 |
| openSUSE:Tumbleweed | libreoffice | 0 | 5.2.3.3-2.2 |
Related vulnerabilities
- CVE-2024-12426 Exposure of Environmental Variables and arbitrary INI file values to an Unauthorized… Also affects libreoffice
- CVE-2024-12425 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')… Also affects libreoffice
- CVE-2024-7788 Improper Digital Signature Invalidation vulnerability in Zip Repair Mode of The Document… Also affects libreoffice
- CVE-2021-25636 LibreOffice supports digital signatures of ODF documents and macros within documents… Also affects libreoffice
- CVE-2021-25633 LibreOffice supports digital signatures of ODF documents and macros within documents… Also affects libreoffice
- CVE-2017-3157 By exploiting the way Apache OpenOffice before 4.1.4 renders embedded objects, an… Also affects libreoffice
- CVE-2017-12607 A vulnerability in OpenOffice's PPT file parser before 4.1.4, and specifically in… Also affects libreoffice
- CVE-2016-10327 LibreOffice before 2016-12-22 has an out-of-bounds write caused by a heap-based buffer… Also affects libreoffice