GHSA-c825-6ph3-4h84
Medium · 5.4CVSS
5.4
EPSS
—
Published
Mar 4, 2026
CISA due date
—
The record
Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Maven | org.apache.activemq:activemq-all | 0 | 5.19.2 |
| Maven | org.apache.activemq:activemq-all | 6.0.0 | 6.1.9 |
| Maven | org.apache.activemq:activemq-all | 6.2.0 | 6.2.1 |
| Maven | org.apache.activemq:activemq-mqtt | 0 | 5.19.2 |
| Maven | org.apache.activemq:activemq-mqtt | 6.0.0 | 6.1.9 |
| Maven | org.apache.activemq:activemq-mqtt | 6.2.0 | 6.2.1 |
| Maven | org.apache.activemq:apache-activemq | 0 | 5.19.2 |
| Maven | org.apache.activemq:apache-activemq | 6.0.0 | 6.1.9 |
| Maven | org.apache.activemq:apache-activemq | 6.2.0 | 6.2.1 |
Related vulnerabilities
- CVE-2025-66168 WARNING: Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous… Same vulnerability
- CVE-2026-110264 An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before… CWE-190
- CVE-2026-53615 util-linux is a random collection of Linux utilities. CWE-190
- CVE-2026-106574 ImageMagick is free and open-source software used for editing and manipulating digital… CWE-190
- CVE-2026-106571 ImageMagick is free and open-source software used for editing and manipulating digital… CWE-190
- CVE-2026-75820 GNU Aspell contains an integer truncation vulnerability in the WritableDict::add()… CWE-190
- CVE-2026-102621 A vulnerability was identified in Freedesktop Poppler up to 26.08.0. CWE-190
- CVE-2026-102620 A vulnerability was determined in Freedesktop Poppler 26.06.0/26.07.0/26.08.0. CWE-190