CVE-2025-66168
Medium · 5.4CVSS
5.4
EPSS
0.8%
Published
Mar 4, 2026
CISA due date
—
The record
WARNING: Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases. See the following for more details: https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt https://www.cve.org/CVERecord?id=CVE-2026-40046 Original Report: Apache ActiveMQ does not properly validate the remaining length field which may lead to an overflow during the decoding of malformed packets. When this integer overflow occurs, ActiveMQ may incorrectly compute the total Remaining Length and subsequently misinterpret the payload as multiple MQTT control packets which makes the broker susceptible to unexpected behavior when interacting with non-compliant clients. This behavior violates the MQTT v3.1.1 specification, which restricts Remaining Length to a maximum of 4 bytes. The scenario occurs on established connections after the authentication process. Brokers that are not enabling mqtt transport connectors are not impacted. This issue affects Apache ActiveMQ: before 5.19.2, 6.0.0 to 6.1.8, and 6.2.0 Users are recommended to upgrade to version 5.19.2, 6.1.9, or 6.2.1, which fixes the issue.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Maven | org.apache.activemq:activemq-all | 0 | 5.19.2 |
| Maven | org.apache.activemq:activemq-all | 6.0.0 | 6.1.9 |
| Maven | org.apache.activemq:activemq-all | 6.2.0 | 6.2.1 |
| Maven | org.apache.activemq:activemq-mqtt | 0 | 5.19.2 |
| Maven | org.apache.activemq:activemq-mqtt | 6.0.0 | 6.1.9 |
| Maven | org.apache.activemq:activemq-mqtt | 6.2.0 | 6.2.1 |
| Maven | org.apache.activemq:apache-activemq | 0 | 5.19.2 |
| Maven | org.apache.activemq:apache-activemq | 6.0.0 | 6.1.9 |
| Maven | org.apache.activemq:apache-activemq | 6.2.0 | 6.2.1 |
Related vulnerabilities
- GHSA-c825-6ph3-4h84 Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound Same vulnerability
- CVE-2026-110264 An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before… CWE-190
- CVE-2026-53615 util-linux is a random collection of Linux utilities. CWE-190
- CVE-2026-106574 ImageMagick is free and open-source software used for editing and manipulating digital… CWE-190
- CVE-2026-106571 ImageMagick is free and open-source software used for editing and manipulating digital… CWE-190
- CVE-2026-75820 GNU Aspell contains an integer truncation vulnerability in the WritableDict::add()… CWE-190
- CVE-2026-102621 A vulnerability was identified in Freedesktop Poppler up to 26.08.0. CWE-190
- CVE-2026-102620 A vulnerability was determined in Freedesktop Poppler 26.06.0/26.07.0/26.08.0. CWE-190