Cloudanix VulnDB

CVE-2026-53421

Critical · 9.8

CVSS

9.8

EPSS

1.1%

Published

Jul 20, 2026

CISA due date

—

The record

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements can achieve remote code execution through the connector subsystem by relying on scripted connectors' (REST and SQL) capability to run Groovy scripts. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by hardening the Groovy security sandbox.

Affected packages

Ecosystem Package Introduced Fixed

Related vulnerabilities