Cloudanix VulnDB

CVE-2026-33539

High · 7.2

CVSS

7.2

EPSS

0.7%

Published

Mar 24, 2026

CISA due date

—

The record

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.59 and 9.6.0-alpha.53, an attacker with master key access can execute arbitrary SQL statements on the PostgreSQL database by injecting SQL metacharacters into field name parameters of the aggregate $group pipeline stage or the distinct operation. This allows privilege escalation from Parse Server application-level administrator to PostgreSQL database-level access. Only Parse Server deployments using PostgreSQL are affected. MongoDB deployments are not affected. This issue has been patched in versions 8.6.59 and 9.6.0-alpha.53.

Affected packages

Ecosystem Package Introduced Fixed
npm parse-server 0 8.6.59
npm parse-server 9.0.0 9.6.0-alpha.53

Related vulnerabilities