Cloudanix VulnDB

CVE-2026-33538

High · 7.5

CVSS

7.5

EPSS

0.8%

Published

Mar 24, 2026

CISA due date

—

The record

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.58 and 9.6.0-alpha.52, an unauthenticated attacker can cause denial of service by sending authentication requests with arbitrary, unconfigured provider names. The server executes a database query for each unconfigured provider before rejecting the request, and since no database index exists for unconfigured providers, each request triggers a full collection scan on the user database. This can be parallelized to saturate database resources. This issue has been patched in versions 8.6.58 and 9.6.0-alpha.52.

Affected packages

Ecosystem Package Introduced Fixed
npm parse-server 0 8.6.58
npm parse-server 9.0.0 9.6.0-alpha.52

Related vulnerabilities