Cloudanix VulnDB

CVE-2026-32829

High · 7.5

CVSS

7.5

EPSS

0.7%

Published

Mar 20, 2026

CISA due date

—

The record

lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.

Affected packages

Ecosystem Package Introduced Fixed
crates.io lz4_flex 0 0.11.6
crates.io lz4_flex 0.0.0-0 0.11.6
crates.io lz4_flex 0.12.0 0.12.1
Chainguard garage-1 0 1.3.1-r3
Chainguard garage-2 0 2.2.0-r2
Chainguard garage-2.2 0 2.2.0-r3
Chainguard parseable 0 2.6.1-r1
Chainguard py3.10-hf-xet 0 1.4.2-r1
Chainguard py3.11-hf-xet 0 1.4.2-r1
Chainguard py3.13-hf-xet 0 1.4.2-r1
Chainguard qdrant 0 1.17.0-r5
Wolfi parseable 0 2.6.1-r1
Wolfi py3.10-hf-xet 0 1.4.2-r1
Wolfi py3.11-hf-xet 0 1.4.2-r1
Wolfi py3.13-hf-xet 0 1.4.2-r1
Wolfi qdrant 0 1.17.0-r5

Related vulnerabilities