CVE-2026-31872
High · 7.5CVSS
7.5
EPSS
0.5%
Published
Mar 11, 2026
CISA due date
—
The record
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.6 and 8.6.32, the protectedFields class-level permission (CLP) can be bypassed using dot-notation in query WHERE clauses and sort parameters. An attacker can use dot-notation to query or sort by sub-fields of a protected field, enabling a binary oracle attack to enumerate protected field values. This affects both MongoDB and PostgreSQL deployments. This vulnerability is fixed in 9.6.0-alpha.6 and 8.6.32.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | parse-server | 0 | 8.6.32 |
| npm | parse-server | 9.0.0-alpha.1 | 9.6.0-alpha.6 |
Related vulnerabilities
- GHSA-r2m8-pxm9-9c4g Parse Server has a protected fields bypass via dot-notation in query and sort Same vulnerability
- GHSA-97pr-9hgg-3p8r parse-server: LiveQuery discloses object data to a subscriber across an ACL read-access… Also affects parse-server
- GHSA-wmwx-jr2p-4j4r parse-server: Relation `$relatedTo` query bypasses `protectedFields` and owning-object ACL Also affects parse-server
- GHSA-7wqv-xjf3-x35v parse-server: Stored XSS via trailing-dot filename bypassing file upload extension… Also affects parse-server
- GHSA-p84r-h6rx-f2xr parse-server: Server option routeAllowList is bypassable through batch sub-requests Also affects parse-server
- GHSA-cgxm-vr2f-6fj8 parse-server: Denial of service via exponential-time processing of deeply nested query… Also affects parse-server
- CVE-2026-53726 Parse Server is an open source backend that can be deployed to any infrastructure that… Also affects parse-server
- CVE-2026-53724 Parse Server is an open source backend that can be deployed to any infrastructure that… Also affects parse-server