Cloudanix VulnDB

CVE-2026-31871

Critical · 9.8

CVSS

9.8

EPSS

0.6%

Published

Mar 11, 2026

CISA due date

—

The record

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.5 and 8.6.31, a SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The sub-key name is interpolated directly into SQL string literals without escaping. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL via a crafted sub-key name containing single quotes, potentially executing commands or reading data from the database, bypassing CLPs and ACLs. Only Postgres deployments are affected. This vulnerability is fixed in 9.6.0-alpha.5 and 8.6.31.

Affected packages

Ecosystem Package Introduced Fixed
npm parse-server 0 8.6.31
npm parse-server 9.0.0-alpha.1 9.6.0-alpha.5

Related vulnerabilities