Cloudanix VulnDB

CVE-2026-28780

Critical · 9.8

CVSS

9.8

EPSS

1.6%

Published

May 5, 2026

CISA due date

—

The record

Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Affected packages

Ecosystem Package Introduced Fixed
openSUSE:Leap 16.0 apache2 0 2.4.66-160000.2.1
openSUSE:Leap 16.0 apache2-devel 0 2.4.66-160000.2.1
openSUSE:Leap 16.0 apache2-event 0 2.4.66-160000.2.1
openSUSE:Leap 16.0 apache2-manual 0 2.4.66-160000.2.1
openSUSE:Leap 16.0 apache2-prefork 0 2.4.66-160000.2.1
openSUSE:Leap 16.0 apache2-utils 0 2.4.66-160000.2.1
openSUSE:Leap 16.0 apache2-worker 0 2.4.66-160000.2.1
openSUSE:Tumbleweed apache2 0 2.4.67-1.1

Related vulnerabilities