CVE-2026-23982
Medium · 6.5CVSS
6.5
EPSS
0.5%
Published
Feb 24, 2026
CISA due date
—
The record
An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| PyPI | apache-superset | 0 | 6.0.0 |
Related vulnerabilities
- GHSA-3m2g-v7jf-7fxc Apache Superset Improper Authorization allows low-privileged users to bypass access… Same vulnerability
- GHSA-48m2-v2r8-h23m Apache Superset: Incomplete DISALLOWED_SQL_FUNCTIONS default list for ClickHouse engine Also affects apache-superset
- GHSA-gvxg-9hqx-f4rg Apache Superset allows privileged users to conduct error-based SQL Injection Also affects apache-superset
- GHSA-h294-8fxm-m2pj Apache Superset allows authenticated users to view sensitive data without explicit… Also affects apache-superset
- GHSA-mwf2-qr4v-94h2 Apache Superset: Read-Only Bypass via Improper Input Validation on PostgreSQL Connections Also affects apache-superset
- CVE-2026-23984 An Improper Input Validation vulnerability exists in Apache Superset that allows an… Also affects apache-superset
- CVE-2026-23983 A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated… Also affects apache-superset
- CVE-2026-23980 Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection')… Also affects apache-superset