Cloudanix VulnDB

CVE-2026-23984

Medium · 6.5

CVSS

6.5

EPSS

0.4%

Published

Feb 24, 2026

CISA due date

—

The record

An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

Affected packages

Ecosystem Package Introduced Fixed
PyPI apache-superset 0 6.0.0

Related vulnerabilities