CVE-2026-22773
Medium · 6.5CVSS
6.5
EPSS
0.4%
Published
Jan 10, 2026
CISA due date
—
The record
vLLM is an inference and serving engine for large language models (LLMs). In versions from 0.6.4 to before 0.12.0, users can crash the vLLM engine serving multimodal models that use the Idefics3 vision model implementation by sending a specially crafted 1x1 pixel image. This causes a tensor dimension mismatch that results in an unhandled runtime error, leading to complete server termination. This issue has been patched in version 0.12.0.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| PyPI | vllm | 0.6.4 | 0.12.0 |
| pypi | vllm | 0.6.4 | No fix |
Related vulnerabilities
- GHSA-grg2-63fw-f2qr vLLM is vulnerable to DoS in Idefics3 vision models via image payload with ambiguous… Same vulnerability
- CVE-2026-22778 vLLM is an inference and serving engine for large language models (LLMs). Also affects vllm
- GHSA-4r2x-xpjr-7cvv vLLM has RCE In Video Processing Also affects vllm
- GHSA-qh4c-xf7m-gxfc vLLM vulnerable to Server-Side Request Forgery (SSRF) through MediaConnector Also affects vllm
- CVE-2026-24779 vLLM vulnerable to Server-Side Request Forgery (SSRF) through MediaConnector Also affects vllm
- GHSA-2pc9-4j83-qjmr vLLM affected by RCE via auto_map dynamic module loading during model initialization Also affects vllm
- CVE-2026-22807 vLLM affected by RCE via auto_map dynamic module loading during model initialization Also affects vllm
- GHSA-mcmc-2m55-j8jj vLLM introduced enhanced protection for CVE-2025-62164 Also affects vllm