CVE-2026-22704
High · 8.0CVSS
8.0
EPSS
1.0%
Published
Jan 10, 2026
CISA due date
—
The record
HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | @haxtheweb/haxcms-nodejs | 11.0.6 | 25.0.0 |
Related vulnerabilities
- GHSA-3fm2-xfq7-7778 HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover Same vulnerability
- CVE-2026-46357 HAX CMS helps manage microsite universe with PHP or NodeJs backends. Also affects @haxtheweb/haxcms-nodejs
- CVE-2026-46496 HAX CMS helps manage microsite universe with PHP or NodeJs backends. Also affects @haxtheweb/haxcms-nodejs
- CVE-2026-46511 HAX CMS helps manage microsite universe with PHP or NodeJs backends. Also affects @haxtheweb/haxcms-nodejs
- CVE-2026-46395 HAX CMS helps manage microsite universe with PHP or NodeJs backends. Also affects @haxtheweb/haxcms-nodejs
- CVE-2026-46393 HAX CMS helps manage microsite universe with PHP or NodeJs backends. Also affects @haxtheweb/haxcms-nodejs
- CVE-2026-46396 HAX CMS helps manage microsite universe with PHP or NodeJs backends. Also affects @haxtheweb/haxcms-nodejs
- GHSA-g2g8-95qg-v35h HaxCMS has a stored Cross-Site Scripting (XSS) bypass in its saveNode endpoint Also affects @haxtheweb/haxcms-nodejs