CVE-2025-9390
Medium · 5.3CVSS
5.3
EPSS
0.3%
Published
Aug 24, 2025
CISA due date
—
Cloudanix analysis
A local flaw in a common text-processing tool can let someone already on the system cause crashes or small unauthorized changes until the software is updated.
- Exploitation
- Local Privilege
- Attacker needs
- Low Privilege
- Complexity
- Low
- Impact
- Data Tampering
- Component
- Application
- Class
- Buffer Overflow
- Remediation
- Upgrade
- Effort
- Low
- Patch risk
- Low
What it actually does
Local buffer overflow in the main function of src/xxd/xxd.c triggered by crafted input to the xxd component.
Why it matters to the business
Attackers with local access can cause limited memory corruption on developer or server systems running affected vim versions, potentially leading to crashes or minor unauthorized actions; high ecosystem prevalence increases patch urgency for organizations relying on vim utilities.
How an attack unfolds
An attacker with local shell access supplies malicious input to xxd that overflows a buffer in main, allowing limited read/write operations; public exploit code facilitates testing or weaponization on unpatched systems.
How to fix it
Upgrade vim to version 9.1.1616 or later; apply commit eeef7c77436a78cd27047b0f5fa6925d56de3cb0 in the vim/vim GIT repository; rebuild xxd from the patched source.
How to confirm the fix worked
Verify installed vim version is at least 9.1.1616; confirm xxd binary was built from source containing commit eeef7c77436a78cd27047b0f5fa6925d56de3cb0; test with known-triggering inputs to ensure no crash occurs.
Typical attack path
- Obtain local user access to a target system
- Identify presence of vulnerable xxd binary
- Craft and supply oversized or malformed input via command line or file
- Trigger buffer overflow to achieve limited memory corruption
- Leverage corruption for crash, information leak, or constrained code execution
How to detect it
Review system logs and process execution history for repeated or anomalous xxd invocations; inspect core dumps or crash reports involving xxd on systems running versions prior to 9.1.1616.
What your security team should do
- Immediately upgrade all vim installations to 9.1.1616 or apply the referenced patch
- Scan build pipelines and developer workstations for vulnerable xxd versions
- Restrict local access and monitor for unusual xxd process behavior until patched
- Add the fixed commit hash to internal vulnerability tracking and dependency scanners
The record
A security flaw has been discovered in vim up to 9.1.1615. Affected by this vulnerability is the function main of the file src/xxd/xxd.c of the component xxd. The manipulation results in buffer overflow. The attack requires a local approach. The exploit has been released to the public and may be exploited. Upgrading to version 9.1.1616 addresses this issue. The patch is identified as eeef7c77436a78cd27047b0f5fa6925d56de3cb0. It is recommended to upgrade the affected component.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | vim | 0 | No fix |
| Debian:12 | vim | 0 | No fix |
| Debian:13 | vim | 0 | No fix |
| Debian:14 | vim | 0 | No fix |
Related vulnerabilities
- CVE-2025-53905 Vim is an open source, command line text editor. Also affects vim
- CVE-2025-53906 Vim is an open source, command line text editor. Also affects vim
- CVE-2025-29768 Vim, a text editor, is vulnerable to potential data loss with zip.vim and special crafted… Also affects vim
- CVE-2025-27423 Vim is an open source, command line text editor. Also affects vim
- CVE-2025-26603 Vim is a greatly improved version of the good old UNIX editor Vi. Also affects vim
- CVE-2025-1215 A vulnerability classified as problematic was found in vim up to 9.1.1096. Also affects vim
- CVE-2025-24014 Vim is an open source, command line text editor. Also affects vim
- CVE-2025-22134 When switching to other buffers using the :all command and visual mode still being… Also affects vim