Cloudanix VulnDB

CVE-2025-1215

None

CVSS

—

EPSS

0.5%

Published

Feb 12, 2025

CISA due date

—

Cloudanix analysis

Monitor only SSVC: Track

A bug in the vim text editor lets someone on the same computer make it crash or misbehave with a special command, and updating the program fixes the problem.

Exploitation
Local Privilege
Attacker needs
Local User
Complexity
Moderate
Impact
Other
Component
Application
Class
Memory Corruption
Remediation
Upgrade
Effort
Low
Patch risk
Low

What it actually does

The vulnerability allows local attackers to trigger memory corruption in vim by supplying a specially crafted --log argument to src/main.c.

Why it matters to the business

Attackers with local access could crash the vim editor or potentially execute arbitrary code, disrupting developer workflows and requiring urgent updates across environments using the editor.

How an attack unfolds

A local attacker invokes vim with a manipulated --log argument that triggers memory corruption in the affected code path, potentially leading to process crash or code execution.

How to fix it

Upgrade vim to version 9.1.1097 or apply the patch at commit c5654b84480822817bb7b69ebc97c174c91185e9.

How to confirm the fix worked

Confirm the installed vim version is 9.1.1097 or later and verify the presence of commit c5654b84480822817bb7b69ebc97c174c91185e9 in the source.

Typical attack path

  1. Identify local systems running vulnerable vim versions
  2. Craft a command line supplying a malicious --log argument
  3. Execute vim locally to trigger the memory corruption

How to detect it

Review command-line audit logs and process creation events for vim invocations containing unusual --log arguments; inspect system logs for associated memory errors or crashes.

What your security team should do

  • Upgrade all vim installations to the fixed version immediately
  • Review and restrict use of the --log flag in scripts and automation
  • Monitor systems for unexpected vim process terminations

The record

A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.

Affected packages

Ecosystem Package Introduced Fixed
Debian:11 vim 0 No fix
Debian:12 vim 0 No fix
Debian:13 vim 0 2:9.1.1113-1
Debian:14 vim 0 2:9.1.1113-1
SUSE:Linux Enterprise Micro 5.1 vim 0 9.1.1101-150000.5.69.1
SUSE:Linux Enterprise Micro 5.2 vim 0 9.1.1101-150000.5.69.1
SUSE:Linux Enterprise Micro 5.3 vim 0 9.1.1101-150000.5.69.1
SUSE:Linux Enterprise Micro 5.4 vim 0 9.1.1101-150000.5.69.1
SUSE:Linux Enterprise Micro 5.5 vim 0 9.1.1101-150500.20.21.1
SUSE:Linux Enterprise Module for Basesystem 15 SP6 vim 0 9.1.1101-150500.20.21.1
SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 vim 0 9.1.1101-150500.20.21.1
SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 vim 0 9.1.1101-17.41.1
openSUSE:Leap 15.6 vim 0 9.1.1101-150500.20.21.1

Related vulnerabilities