Cloudanix VulnDB

CVE-2025-68675

High · 7.5

CVSS

7.5

EPSS

1.9%

Published

Jan 16, 2026

CISA due date

—

The record

In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields could be exposed. Users are recommended to upgrade to 3.1.6 or later for Airflow 3, and 2.11.1 or later for Airflow 2 which fixes this issue

Affected packages

Ecosystem Package Introduced Fixed
PyPI apache-airflow 0 2.11.1
PyPI apache-airflow 3.0.0b1 3.1.6
Bitnami airflow 0 3.1.6
Chainguard airflow-2 0 2.11.1-r0
Chainguard airflow-3 0 3.1.6-r0
Chainguard airflow-core-2 0 2.11.1-r0
Chainguard airflow-core-3 0 3.1.6-r0
Wolfi airflow-3 0 3.1.6-r0

Related vulnerabilities