CVE-2026-24098
Medium · 6.5CVSS
6.5
EPSS
0.8%
Published
Feb 9, 2026
CISA due date
—
The record
Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| PyPI | apache-airflow | 0 | 3.1.7 |
Related vulnerabilities
- GHSA-5g2w-9f8g-g5q7 Apache Airflow UI Exposes DAG Import Errors to Unauthorized Authenticated Users Same vulnerability
- GHSA-8r55-rv5w-6pfm Apache Airflow exposes sensitive information in its log files Also affects apache-airflow
- GHSA-r837-hpv7-pc2f Apache Airflow vulnerable to Code Injection in the web-server context via LogTemplate… Also affects apache-airflow
- CVE-2024-56373 DAG Author (who already has quite a lot of permissions) could manipulate database of… Also affects apache-airflow
- CVE-2025-27555 Airflow versions before 2.11.1 have a vulnerability that allows authenticated users with… Also affects apache-airflow
- GHSA-gfw7-2v73-69wg Apache Airflow error reporting may expose full kwargs Also affects apache-airflow
- CVE-2025-65995 When a DAG failed during parsing, Airflow’s error-reporting in the UI could include the… Also affects apache-airflow
- CVE-2026-22922 Apache Airflow versions 3.1.0 through 3.1.6 contain an authorization flaw that can allow… Also affects apache-airflow