Cloudanix VulnDB

CVE-2025-68670

Critical · 9.1

CVSS

9.1

EPSS

1.4%

Published

Jan 27, 2026

CISA due date

—

The record

xrdp is an open source RDP server. xrdp before v0.10.5 contains an unauthenticated stack-based buffer overflow vulnerability. The issue stems from improper bounds checking when processing user domain information during the connection sequence. If exploited, the vulnerability could allow remote attackers to execute arbitrary code on the target system. The vulnerability allows an attacker to overwrite the stack buffer and the return address, which could theoretically be used to redirect the execution flow. The impact of this vulnerability is lessened if a compiler flag has been used to build the xrdp executable with stack canary protection. If this is the case, a second vulnerability would need to be used to leak the stack canary value. Upgrade to version 0.10.5 to receive a patch. Additionally, do not rely on stack canary protection on production systems.

Affected packages

Ecosystem Package Introduced Fixed
Mageia:9 xrdp 0 0.9.23.1-1.2.mga9
SUSE:Linux Enterprise Module for Basesystem 15 SP7 xrdp 0 0.9.13.1-150600.15.6.1
SUSE:Linux Enterprise Server 15 SP6-LTSS xrdp 0 0.9.13.1-150600.15.6.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP6 xrdp 0 0.9.13.1-150600.15.6.1
openSUSE:Leap 15.6 xrdp 0 0.9.13.1-150600.15.6.1
openSUSE:Leap 16.0 xrdp 0 0.9.26-bp160.2.1
openSUSE:Tumbleweed xrdp 0 0.9.27-1.1

Related vulnerabilities