Cloudanix VulnDB

CVE-2025-66675

High · 8.2

Apache Struts has a Denial of Service vulnerability

CVSS

8.2

EPSS

0.6%

Published

Dec 10, 2025

CISA due date

—

The record

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

Affected packages

Ecosystem Package Introduced Fixed
Maven org.apache.struts:struts2-core 2.0.0 6.8.0
Maven org.apache.struts:struts2-core 7.0.0 7.1.1
maven org.apache.struts/struts2-core 2.0.0 6.8.0
maven org.apache.struts/struts2-core 7.0.0 7.1.1

Related vulnerabilities