Cloudanix VulnDB

CVE-2025-64775

High · 7.5

Apache Struts is Vulnerable to DoS via File Leak

CVSS

7.5

EPSS

1.5%

Published

Dec 1, 2025

CISA due date

—

The record

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

Affected packages

Ecosystem Package Introduced Fixed
Maven org.apache.struts:struts2-core 2.0.0 No fix
Maven org.apache.struts:struts2-core 2.5.0 No fix
Maven org.apache.struts:struts2-core 6.0.0 6.8.0
Maven org.apache.struts:struts2-core 7.0.0 7.1.1
maven org.apache.struts/struts2-core 2.0.0 No fix
maven org.apache.struts/struts2-core 2.5.0 No fix
maven org.apache.struts/struts2-core 6.0.0 6.8.0
maven org.apache.struts/struts2-core 7.0.0 7.1.1

Related vulnerabilities