Cloudanix VulnDB

CVE-2025-6141

Low · 3.3

CVSS

3.3

EPSS

0.2%

Published

Jun 16, 2025

CISA due date

—

Cloudanix analysis

Schedule a fix SSVC: Track

A problem in a widely used terminal library lets local users crash certain programs by feeding bad settings data, fixed by installing the latest version.

Exploitation
Local Privilege
Attacker needs
Local User
Complexity
Low
Impact
Denial Of Service
Component
Library
Class
Buffer Overflow
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Stack-based buffer overflow in postprocess_termcap within tinfo/parse_entry.c caused by malformed termcap data manipulation.

Why it matters to the business

Local denial-of-service crashes in terminal-handling applications on systems using affected ncurses packages, with limited operational disruption due to low severity and local-only access requirement.

How an attack unfolds

A local attacker supplies crafted termcap input that triggers an overflow during parsing in the vulnerable function, leading to application instability; no widespread exploitation or threat actor activity observed given low EPSS and absence from KEV.

How to fix it

Upgrade GNU ncurses to 6.5-20250329; for Mageia 5 apply libssh package update to 0.6.5-1.1.mga5.

How to confirm the fix worked

Confirm installed ncurses version meets or exceeds 6.5-20250329 and test termcap parsing with boundary inputs for stability.

Typical attack path

  1. Obtain local system access
  2. Craft malicious termcap entry targeting postprocess_termcap
  3. Invoke an ncurses-using application to trigger parsing and overflow

How to detect it

Review system and application logs for ncurses-related crashes or segmentation faults following termcap processing; correlate with local user activity around affected binaries.

What your security team should do

  • Apply the specified ncurses and dependent package upgrades promptly
  • Restrict local user influence over termcap files where feasible
  • Track ecosystem dependents for downstream impact

The record

A vulnerability has been found in GNU ncurses up to 6.5-20250322 and classified as problematic. This vulnerability affects the function postprocess_termcap of the file tinfo/parse_entry.c. The manipulation leads to stack-based buffer overflow. The attack needs to be approached locally. Upgrading to version 6.5-20250329 is able to address this issue. It is recommended to upgrade the affected component.

Affected packages

Ecosystem Package Introduced Fixed
Debian:11 ncurses 0 No fix
Debian:12 ncurses 0 No fix
Debian:13 ncurses 0 No fix

Related vulnerabilities