CVE-2025-53020
NoneCVSS
—
EPSS
5.0%
Published
Jul 10, 2025
CISA due date
—
Cloudanix analysis
A problem in the web server software can let attackers crash servers or run harmful code by sending certain requests, so organizations should update to the newest version right away.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Network Service
- Class
- Use After Free
- Remediation
- Upgrade
- Effort
- Low
- Patch risk
- Low
What it actually does
Use-after-free condition in Apache HTTP Server caused by late release of memory after its effective lifetime, allowing access to dangling pointers in versions 2.4.17 through 2.4.63.
Why it matters to the business
Web servers may crash or allow remote code execution, resulting in service outages, data exposure, and unplanned downtime for organizations relying on affected Apache deployments; upgrade urgency is moderate given low EPSS and absence from KEV.
How an attack unfolds
An attacker sends specially crafted HTTP requests that trigger the memory management error, causing the server to reference already-freed memory that can be manipulated to execute arbitrary code or crash the process.
How to fix it
Upgrade Apache HTTP Server to version 2.4.64. For Debian 13 systems apply package version 6.12.35-1; for git builds apply commit 7e926454793abd7d71b6afc8bd1ec1648752c6ad.
How to confirm the fix worked
Confirm running version reports 2.4.64 or newer via httpd -v or package manager; re-scan with vulnerability assessment tools to verify the use-after-free condition is no longer present.
Typical attack path
- Scan for publicly reachable Apache HTTP Server instances running versions 2.4.17-2.4.63
- Send crafted requests designed to exercise the late-release memory path
- Reuse dangling pointers to achieve code execution or denial of service
- Establish persistence or exfiltrate data if exploitation succeeds
How to detect it
Review Apache error and access logs for segmentation faults or abnormal process terminations coinciding with unusual request patterns; correlate with system memory or crash-dump artifacts.
What your security team should do
- Prioritize upgrade of all internet-facing Apache instances to the fixed versions listed
- Apply compensating controls such as WAF rules while patches are deployed
- Monitor server stability and memory-related logs during rollout
- Track downstream package updates for any dependent Linux distributions
The record
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63. Users are recommended to upgrade to version 2.4.64, which fixes the issue.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Alpine:v3.19 | apache2 | 0 | 2.4.64-r0 |
| Alpine:v3.20 | apache2 | 0 | 2.4.64-r0 |
| Alpine:v3.21 | apache2 | 0 | 2.4.64-r0 |
| Alpine:v3.22 | apache2 | 0 | 2.4.64-r0 |
| Bitnami | apache | 2.4.17 | 2.4.64 |
| Debian:11 | apache2 | 0 | No fix |
| Debian:12 | apache2 | 0 | No fix |
| Debian:13 | apache2 | 0 | No fix |
| Debian:14 | apache2 | 0 | 2.4.64-1 |
| Mageia:9 | apache | 0 | 2.4.65-1.mga9 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | apache2 | 0 | 2.4.58-150600.5.35.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | apache2-prefork | 0 | 2.4.58-150600.5.35.1 |
| SUSE:Linux Enterprise Module for Package Hub 15 SP6 | apache2 | 0 | 2.4.58-150600.5.35.1 |
| SUSE:Linux Enterprise Module for Package Hub 15 SP6 | apache2-event | 0 | 2.4.58-150600.5.35.1 |
| SUSE:Linux Enterprise Module for Server Applications 15 SP6 | apache2-devel | 0 | 2.4.58-150600.5.35.1 |
| SUSE:Linux Enterprise Module for Server Applications 15 SP6 | apache2-utils | 0 | 2.4.58-150600.5.35.1 |
| SUSE:Linux Enterprise Module for Server Applications 15 SP6 | apache2-worker | 0 | 2.4.58-150600.5.35.1 |
| SUSE:Linux Enterprise Server 12 SP5-LTSS | apache2 | 0 | 2.4.51-35.69.1 |
| SUSE:Linux Enterprise Server 12 SP5-LTSS | apache2-tls13 | 0 | 2.4.51-35.69.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | apache2 | 0 | 2.4.51-35.69.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | apache2-tls13 | 0 | 2.4.51-35.69.1 |
| openSUSE:Leap 15.6 | apache2 | 0 | 2.4.58-150600.5.35.1 |
| openSUSE:Leap 15.6 | apache2-devel | 0 | 2.4.58-150600.5.35.1 |
| openSUSE:Leap 15.6 | apache2-event | 0 | 2.4.58-150600.5.35.1 |
| openSUSE:Leap 15.6 | apache2-manual | 0 | 2.4.58-150600.5.35.1 |
| openSUSE:Leap 15.6 | apache2-prefork | 0 | 2.4.58-150600.5.35.1 |
| openSUSE:Leap 15.6 | apache2-utils | 0 | 2.4.58-150600.5.35.1 |
| openSUSE:Leap 15.6 | apache2-worker | 0 | 2.4.58-150600.5.35.1 |
| openSUSE:Tumbleweed | apache2 | 0 | 2.4.64-1.1 |
Related vulnerabilities
- CVE-2025-49630 In certain proxy configurations, a denial of service attack against Apache HTTP Server… Also affects apache2
- CVE-2025-49812 In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP… Also affects apache2
- CVE-2024-43394 Server-Side Request Forgery (SSRF) in Apache HTTP Server on Windows allows to potentially… Also affects apache2
- CVE-2024-47252 Insufficient escaping of user-supplied data in mod_ssl in Apache HTTP Server 2.4.63 and… Also affects apache2
- CVE-2025-23048 In some mod_ssl configurations on Apache HTTP Server 2.4.35 through to 2.4.63, an access… Also affects apache2
- CVE-2024-42516 HTTP response splitting in the core of Apache HTTP Server allows an attacker who can… Also affects apache2
- CVE-2024-43204 SSRF in Apache HTTP Server with mod_proxy loaded allows an attacker to send outbound… Also affects apache2
- CVE-2021-41773 A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. Also affects apache2