Cloudanix VulnDB

CVE-2025-49812

None

CVSS

—

EPSS

0.6%

Published

Jul 10, 2025

CISA due date

—

Cloudanix analysis

Monitor only SSVC: Track

A specific web server setup can let someone who intercepts network traffic secretly take over users' logged-in sessions.

Exploitation
Adjacent Network
Attacker needs
Other
Complexity
High
Impact
Data Exposure
Component
Network Service
Class
Authorization Bypass
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

In mod_ssl configurations with SSLEngine optional enabled, a man-in-the-middle attacker can trigger an HTTP desynchronisation condition during TLS upgrade to hijack an established HTTP session.

Why it matters to the business

Organizations running affected Apache HTTP Server versions with the optional TLS upgrade setting face risk of session hijacking that could lead to unauthorized access to protected resources and potential data exposure; the low EPSS and absence from known exploited lists indicate limited active threat but still require prompt configuration review.

How an attack unfolds

An attacker positioned between client and server observes a connection using the optional TLS upgrade path, injects crafted requests to desynchronise the HTTP framing, and takes over the session after the upgrade handshake completes.

How to fix it

Upgrade Apache HTTP Server to version 2.4.64 or apply the equivalent fix from commit 7e926454793abd7d71b6afc8bd1ec1648752c6ad; alternatively disable SSLEngine optional and enforce TLS at the connection level instead of using upgrade.

How to confirm the fix worked

Verify the running Apache version is 2.4.64 or newer, confirm SSLEngine optional is not present in any VirtualHost or server configuration, and test that TLS upgrade attempts are rejected or redirected to full TLS connections.

Typical attack path

  1. Position as network man-in-the-middle to observe traffic to an Apache server configured with SSLEngine optional
  2. Wait for or induce a client to initiate an HTTP request that triggers the TLS upgrade mechanism
  3. Inject desynchronizing HTTP data during the upgrade window to break request/response alignment
  4. Hijack the resulting session to issue authenticated requests on behalf of the victim

How to detect it

Review web server access and error logs for unusual TLS upgrade sequences or abrupt session terminations; correlate with network flow data showing MITM-like latency patterns on ports 80/443.

What your security team should do

  • Audit all Apache configurations for SSLEngine optional directives and remove or replace them
  • Schedule upgrade to 2.4.64 across all affected httpd instances within standard change windows
  • Monitor EPSS trend and threat intelligence feeds for any increase in exploitation activity
  • Document the removal of TLS upgrade support and update internal secure configuration baselines

The record

In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.

Affected packages

Ecosystem Package Introduced Fixed
AlmaLinux:10 httpd 0 2.4.63-1.el10_0.2
AlmaLinux:10 httpd-core 0 2.4.63-1.el10_0.2
AlmaLinux:10 httpd-devel 0 2.4.63-1.el10_0.2
AlmaLinux:10 httpd-filesystem 0 2.4.63-1.el10_0.2
AlmaLinux:10 httpd-manual 0 2.4.63-1.el10_0.2
AlmaLinux:10 httpd-tools 0 2.4.63-1.el10_0.2
AlmaLinux:10 mod_ldap 0 2.4.63-1.el10_0.2
AlmaLinux:10 mod_lua 0 2.4.63-1.el10_0.2
AlmaLinux:10 mod_proxy_html 0 1:2.4.63-1.el10_0.2
AlmaLinux:10 mod_session 0 2.4.63-1.el10_0.2
AlmaLinux:10 mod_ssl 0 1:2.4.63-1.el10_0.2
AlmaLinux:8 httpd 0 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
AlmaLinux:8 httpd-devel 0 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
AlmaLinux:8 httpd-filesystem 0 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
AlmaLinux:8 httpd-manual 0 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
AlmaLinux:8 httpd-tools 0 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
AlmaLinux:8 mod_http2 0 1.15.7-10.module_el8.10.0+4044+ea5f78b1.4
AlmaLinux:8 mod_ldap 0 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
AlmaLinux:8 mod_md 0 1:2.0.8-8.module_el8.6.0+2872+fe0ff7aa
AlmaLinux:8 mod_md 0 1:2.0.8-8.module_el8.6.0+3031+fb177b09
AlmaLinux:8 mod_proxy_html 0 1:2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
AlmaLinux:8 mod_session 0 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
AlmaLinux:8 mod_ssl 0 1:2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
AlmaLinux:9 httpd 0 2.4.62-4.el9_6.4
AlmaLinux:9 httpd-core 0 2.4.62-4.el9_6.4
AlmaLinux:9 httpd-devel 0 2.4.62-4.el9_6.4
AlmaLinux:9 httpd-filesystem 0 2.4.62-4.el9_6.4
AlmaLinux:9 httpd-manual 0 2.4.62-4.el9_6.4
AlmaLinux:9 httpd-tools 0 2.4.62-4.el9_6.4
AlmaLinux:9 mod_ldap 0 2.4.62-4.el9_6.4
AlmaLinux:9 mod_lua 0 2.4.62-4.el9_6.4
AlmaLinux:9 mod_proxy_html 0 1:2.4.62-4.el9_6.4
AlmaLinux:9 mod_session 0 2.4.62-4.el9_6.4
AlmaLinux:9 mod_ssl 0 1:2.4.62-4.el9_6.4
Alpine:v3.19 apache2 0 2.4.64-r0
Alpine:v3.20 apache2 0 2.4.64-r0
Alpine:v3.21 apache2 0 2.4.64-r0
Alpine:v3.22 apache2 0 2.4.64-r0
Bitnami apache 0 2.4.64
Debian:11 apache2 0 No fix
Debian:12 apache2 0 No fix
Debian:13 apache2 0 No fix
Debian:14 apache2 0 2.4.64-1
Mageia:9 apache 0 2.4.65-1.mga9
SUSE:Linux Enterprise Module for Basesystem 15 SP6 apache2 0 2.4.58-150600.5.35.1
SUSE:Linux Enterprise Module for Basesystem 15 SP6 apache2-prefork 0 2.4.58-150600.5.35.1
SUSE:Linux Enterprise Module for Package Hub 15 SP6 apache2 0 2.4.58-150600.5.35.1
SUSE:Linux Enterprise Module for Package Hub 15 SP6 apache2-event 0 2.4.58-150600.5.35.1
SUSE:Linux Enterprise Module for Server Applications 15 SP6 apache2-devel 0 2.4.58-150600.5.35.1
SUSE:Linux Enterprise Module for Server Applications 15 SP6 apache2-utils 0 2.4.58-150600.5.35.1
SUSE:Linux Enterprise Module for Server Applications 15 SP6 apache2-worker 0 2.4.58-150600.5.35.1
SUSE:Linux Enterprise Server 12 SP5-LTSS apache2 0 2.4.51-35.69.1
SUSE:Linux Enterprise Server 12 SP5-LTSS apache2-tls13 0 2.4.51-35.69.1
SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 apache2 0 2.4.51-35.69.1
SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 apache2-tls13 0 2.4.51-35.69.1
openSUSE:Leap 15.6 apache2 0 2.4.58-150600.5.35.1
openSUSE:Leap 15.6 apache2-devel 0 2.4.58-150600.5.35.1
openSUSE:Leap 15.6 apache2-event 0 2.4.58-150600.5.35.1
openSUSE:Leap 15.6 apache2-manual 0 2.4.58-150600.5.35.1
openSUSE:Leap 15.6 apache2-prefork 0 2.4.58-150600.5.35.1
openSUSE:Leap 15.6 apache2-utils 0 2.4.58-150600.5.35.1
openSUSE:Leap 15.6 apache2-worker 0 2.4.58-150600.5.35.1
openSUSE:Leap 16.0 cyrus-imapd 0 3.8.6-bp160.1.1
openSUSE:Tumbleweed apache2 0 2.4.64-1.1
openSUSE:Tumbleweed cyrus-imapd 0 3.8.6-1.1

Related vulnerabilities