CVE-2025-11082
Medium · 5.3CVSS
5.3
EPSS
0.3%
Published
Sep 27, 2025
CISA due date
—
Cloudanix analysis
A local flaw in a common software build tool can let someone on the same computer cause crashes or limited interference during program linking.
- Exploitation
- Local Privilege
- Attacker needs
- Low Privilege
- Complexity
- Low
- Impact
- Other
- Component
- Application
- Class
- Buffer Overflow
- Remediation
- Patch
- Effort
- Low
- Patch risk
- Low
What it actually does
Heap-based buffer overflow in the _bfd_elf_parse_eh_frame function of bfd/elf-eh-frame.c within the GNU Binutils linker component.
Why it matters to the business
Local memory corruption in build and linking processes can cause application crashes, data integrity issues, or limited code execution, increasing operational risk for organizations relying on affected versions in development pipelines; low EPSS and no KEV status indicate limited widespread urgency but published exploit raises patching priority.
How an attack unfolds
An attacker with local access supplies crafted ELF input to the vulnerable linker function, triggering the heap overflow during exception frame parsing; the published exploit demonstrates memory corruption that may be leveraged for further local impact.
How to fix it
Apply the patch ea1a0737c7692737a644af0486b71e4a392cbca8 or upgrade to GNU Binutils 2.46; for github.com/oauth2-proxy/oauth2-proxy/v7 upgrade to version 7.11.0.
How to confirm the fix worked
Verify the installed Binutils version is 2.46 or later and confirm the patch commit is present in the source; test builds with known edge-case ELF inputs to ensure no overflow occurs.
Typical attack path
- Gain local execution rights on a host using vulnerable Binutils
- Prepare malicious input targeting the ELF EH frame parser
- Invoke the linker or build process with the crafted input
- Trigger heap buffer overflow to achieve memory corruption
How to detect it
Review build logs and process execution records for abnormal linker terminations or memory-related errors when processing ELF files; no widespread threat actor activity reported.
What your security team should do
- Prioritize upgrade of Binutils in all build environments within standard change windows
- Scan dependency trees for any indirect use of affected Binutils components
- Monitor for new public exploit code and update local detection rules accordingly
The record
A flaw has been found in GNU Binutils 2.45. Impacted is the function _bfd_elf_parse_eh_frame of the file bfd/elf-eh-frame.c of the component Linker. Executing manipulation can lead to heap-based buffer overflow. The attack is restricted to local execution. The exploit has been published and may be used. This patch is called ea1a0737c7692737a644af0486b71e4a392cbca8. A patch should be applied to remediate this issue. The code maintainer replied with "[f]ixed for 2.46".
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| AlmaLinux:10 | binutils | 0 | 2.41-58.el10_1.2.alma.1 |
| AlmaLinux:10 | binutils-devel | 0 | 2.41-58.el10_1.2.alma.1 |
| AlmaLinux:10 | binutils-gold | 0 | 2.41-58.el10_1.2.alma.1 |
| Chainguard | binutils | 0 | 2.45.1-r1 |
| Chainguard | binutils-dev | 0 | 2.45.1-r1 |
| Chainguard | binutils-doc | 0 | 2.45.1-r1 |
| Chainguard | binutils-gold | 0 | 2.45.1-r1 |
| Wolfi | binutils | 0 | 2.45.1-r1 |
| Wolfi | binutils-dev | 0 | 2.45.1-r1 |
| Wolfi | binutils-doc | 0 | 2.45.1-r1 |
| Wolfi | binutils-gold | 0 | 2.45.1-r1 |
Related vulnerabilities
- CVE-2025-11083 A vulnerability has been found in GNU Binutils 2.45. Also affects binutils
- CVE-2025-5244 A vulnerability was found in GNU Binutils up to 2.44. Also affects binutils
- CVE-2025-11840 A weakness has been identified in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11839 A security flaw has been discovered in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11495 A vulnerability was determined in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11494 A vulnerability was found in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11414 A vulnerability was determined in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11412 A vulnerability has been found in GNU Binutils 2.45. Also affects binutils