CVE-2025-11081
Low · 3.3CVSS
3.3
EPSS
0.2%
Published
Sep 27, 2025
CISA due date
—
Cloudanix analysis
A bug in a common programming tool lets someone with direct access to a computer crash the tool by giving it a specially made file.
- Exploitation
- Local Privilege
- Attacker needs
- Local User
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Application
- Class
- Memory Corruption
- Remediation
- Patch
- Effort
- Low
- Patch risk
- Low
What it actually does
Out-of-bounds read in dump_dwarf_section of binutils/objdump.c triggered by malformed DWARF data in an ELF file, resulting in limited availability impact when run locally.
Why it matters to the business
Developers and build systems using affected Binutils versions face potential crashes during debugging or binary inspection; the listed oauth2-proxy package requires upgrade to 7.1.0, with low EPSS and no KEV indicating limited operational urgency despite public exploit availability after 396 days.
How an attack unfolds
A local attacker prepares an ELF binary containing manipulated DWARF sections, invokes objdump on the file to trigger the out-of-bounds read, and leverages the now-public exploit for denial-of-service; no named threat actors are associated.
How to fix it
Apply the patch referenced as f87a66db645caf8cc0e6fc87b0c28c78a38af59b or upgrade GNU Binutils; for the affected github.com/oauth2-proxy/oauth2-proxy/v7 package, update to version 7.1.0.
How to confirm the fix worked
Rebuild and test objdump against known-good and malformed test cases; verify oauth2-proxy version 7.1.0 or later is deployed and confirm absence of the vulnerable function path.
Typical attack path
- Gain local system access
- Craft ELF file with malformed DWARF data targeting dump_dwarf_section
- Execute objdump against the malicious file
- Observe crash or memory access behavior
How to detect it
Review system logs and process execution records for repeated objdump invocations on untrusted binaries; inspect for segmentation faults or memory errors during DWARF parsing; no specific threat actor campaigns noted.
What your security team should do
- Prioritize patching oauth2-proxy to 7.1.0 where present
- Scan development environments for vulnerable Binutils 2.45 installations
- Monitor for objdump crashes in CI/CD pipelines
- Apply vendor updates as they become available given public exploit status
The record
A vulnerability was detected in GNU Binutils 2.45. This issue affects the function dump_dwarf_section of the file binutils/objdump.c. Performing manipulation results in out-of-bounds read. The attack is only possible with local access. The exploit is now public and may be used. The patch is named f87a66db645caf8cc0e6fc87b0c28c78a38af59b. It is suggested to install a patch to address this issue.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Chainguard | binutils | 0 | 2.45.1-r1 |
| Chainguard | binutils-dev | 0 | 2.45.1-r1 |
| Chainguard | binutils-doc | 0 | 2.45.1-r1 |
| Chainguard | binutils-gold | 0 | 2.45.1-r1 |
| Wolfi | binutils | 0 | 2.45.1-r1 |
| Wolfi | binutils-dev | 0 | 2.45.1-r1 |
| Wolfi | binutils-doc | 0 | 2.45.1-r1 |
| Wolfi | binutils-gold | 0 | 2.45.1-r1 |
Related vulnerabilities
- CVE-2025-11840 A weakness has been identified in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11839 A security flaw has been discovered in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11495 A vulnerability was determined in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11494 A vulnerability was found in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11414 A vulnerability was determined in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11412 A vulnerability has been found in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11413 A vulnerability was found in GNU Binutils 2.45. Also affects binutils
- CVE-2025-11083 A vulnerability has been found in GNU Binutils 2.45. Also affects binutils