CVE-2024-27322
High · 8.8CVSS
8.8
EPSS
23.4%
Published
Apr 29, 2024
CISA due date
—
Cloudanix analysis
A flaw in the R programming language lets attackers run harmful code on a computer simply by tricking someone into opening a specially made data file or package.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Low
- Impact
- Remote Code Execution
- Component
- Application
- Class
- Deserialization
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Deserialization of untrusted data in R versions 1.4.0 through 4.3.x allows arbitrary code execution when a malicious RDS file or R package is loaded.
Why it matters to the business
Compromise of data science and statistical computing environments can lead to data theft, ransomware deployment, or supply-chain attacks against organizations relying on R for analytics or package distribution.
How an attack unfolds
An attacker creates a malicious RDS file or R package containing serialized objects that trigger code execution on load; the file or package is delivered to a victim who interacts with it in an affected R installation, resulting in immediate arbitrary code execution on the end-user system.
How to fix it
Upgrade R to version 4.4.0 or later. For the listed packages apply the following exact fixes: buildkitd (Chainguard) 0.13.1-r2, buildkitd (Wolfi) 0.13.1-r2, buildctl (Chainguard) 0.13.1-r2, buildctl (Wolfi) 0.13.1-r2.
How to confirm the fix worked
Verify R version is 4.4.0 or newer; confirm the listed packages report the fixed versions above; test loading of known-good RDS files and packages to ensure normal operation.
Typical attack path
- Craft malicious RDS file or R package embedding arbitrary code
- Deliver the file via email, repository, or supply chain
- Victim loads the RDS or installs/loads the package in vulnerable R
- Deserialization executes attacker-controlled code
How to detect it
Review logs for unexpected process creation or network activity immediately after RDS file loads; inspect package installation history and file hashes of recently added .rds or .rda files; correlate with user activity involving R.
What your security team should do
- Immediately upgrade all R installations to 4.4.0+ and apply the listed package fixes
- Scan internal package repositories and shared RDS files for signs of tampering
- Restrict loading of untrusted RDS files and R packages until upgrades are complete
- Monitor EPSS score and any new exploit maturity signals given the 898 days since publication
The record
Deserialization of untrusted data can occur in the R statistical programming language, on any version starting at 1.4.0 up to and not including 4.4.0, enabling a maliciously crafted RDS (R Data Serialization) formatted file or R package to run arbitrary code on an end user’s system when interacted with.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:10 | r-base | 0 | No fix |
| Debian:11 | r-base | 0 | No fix |
| Debian:12 | r-base | 0 | No fix |
| Debian:13 | r-base | 0 | 4.4.0-2 |
| Ubuntu:18.04:LTS | r-base | 0 | No fix |
| Ubuntu:20.04:LTS | r-base | 0 | No fix |
| Ubuntu:22.04:LTS | r-base | 0 | No fix |
| Ubuntu:24.04:LTS | r-base | 0 | No fix |
| Ubuntu:24.10 | r-base | 0 | 4.4.1-1 |
| Ubuntu:Pro:14.04:LTS | r-base | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | r-base | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | r-base | 0 | No fix |
| Ubuntu:Pro:20.04:LTS | r-base | 0 | No fix |
Related vulnerabilities
- CVE-2016-8714 An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of… Also affects r-base
- CVE-2026-114724 Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 contains an object injection… CWE-502
- CVE-2026-112081 A vulnerability was determined in hankcs HanLP up to 2.1.0-beta.64. CWE-502
- CVE-2026-96745 Deserialization of untrusted data in the command monitoring support of the MongoDB PHP… CWE-502
- CVE-2026-62107 Unauthenticated PHP Object Injection in Masteriyo - LMS <= 3.4.0 versions. CWE-502
- CVE-2026-62103 Unauthenticated PHP Object Injection in Everest Forms <= 3.6.0 versions. CWE-502
- CVE-2026-62105 Unauthenticated PHP Object Injection in ThemeREX Addons < 2.45.0 versions. CWE-502
- CVE-2026-73699 FileRun before 2026.3.0 contains a PHP object injection vulnerability that allows… CWE-502