CVE-2022-25020
Medium · 5.4CVSS
5.4
EPSS
1.2%
Published
Mar 1, 2022
CISA due date
—
Cloudanix analysis
A flaw in certain monitoring tools could let attackers interfere with how system performance data is collected, so update the tools to the newest version to keep monitoring trustworthy.
- Exploitation
- Other
- Attacker needs
- Other
- Complexity
- Other
- Impact
- Other
- Component
- Other
- Class
- Other
- Remediation
- Other
- Effort
- Other
- Patch risk
- Other
What it actually does
The vulnerability permits an attacker to bypass intended access controls or inject malicious content into Prometheus configuration or admission decisions within the affected operator and webhook components.
Why it matters to the business
Organizations running monitoring infrastructure face potential tampering with metrics pipelines or unauthorized cluster changes, increasing risk of undetected system issues or compliance violations; low exploit prevalence reduces immediate urgency but requires prompt patching of all listed packages.
How an attack unfolds
An attacker identifies an exposed prometheus-admission-webhook or config-reloader instance, crafts a malicious request or configuration payload that exploits the flaw to alter scrape targets or inject rules, then uses the modified setup to exfiltrate data or pivot within the environment.
How to fix it
Upgrade all affected Chainguard and Wolfi packages to the versions fixed in 0.72.0-r1; verify no older images remain in registries or running deployments; apply network segmentation to limit exposure of webhook endpoints until patched.
How to confirm the fix worked
Confirm running container images report version 0.72.0-r1 or newer via image inspection or pod spec checks; re-test admission webhook behavior against known malicious payloads after upgrade.
Typical attack path
- Scan for publicly reachable prometheus-operator or admission-webhook endpoints
- Submit crafted configuration or admission request exploiting the flaw
- Achieve modification of Prometheus scrape jobs or alert rules
- Leverage altered monitoring to mask follow-on activity or collect sensitive metrics
How to detect it
Review admission webhook logs and config-reloader audit trails for unexpected configuration changes; search Kubernetes audit logs for anomalous updates to Prometheus custom resources originating from the webhook service account.
What your security team should do
- Immediately inventory all deployments of the listed prometheus packages and schedule upgrades to 0.72.0-r1
- Add package version checks to CI/CD pipelines to prevent reintroduction of vulnerable images
- Monitor EPSS trend and revisit if score increases; treat as medium priority given low current exploitation likelihood
The record
A cross-site scripting (XSS) vulnerability in Pluxml v5.8.7 allows attackers to execute arbitrary web scripts or HTML via a crafted payload in the thumbnail path of a blog post.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:10 | pluxml | 0 | No fix |
| Ubuntu:16.04:LTS | pluxml | 0 | No fix |
| Ubuntu:18.04:LTS | pluxml | 0 | No fix |
| Ubuntu:20.04:LTS | pluxml | 0 | No fix |
| Ubuntu:22.04:LTS | pluxml | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | pluxml | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | pluxml | 0 | No fix |
| Ubuntu:Pro:20.04:LTS | pluxml | 0 | No fix |
Related vulnerabilities
- CVE-2022-25018 Pluxml v5.8.7 was discovered to allow attackers to execute arbitrary code via crafted PHP… Also affects pluxml
- CVE-2026-62990 Shopper is a Headless e-commerce Admin Panel. CWE-79
- CVE-2026-117645 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')… CWE-79
- CVE-2026-94175 Unauthenticated Cross Site Scripting (XSS) in All In One Login <= 2.4.1 versions. CWE-79
- CVE-2026-7004 WIT SynApps Runtime through 1.4.11 contains a pre-authentication reflected cross-site… CWE-79
- CVE-2026-54855 Unauthenticated Cross Site Scripting (XSS) in Profile Builder <= 4.0.5 versions. CWE-79
- CVE-2026-48201 Unauthenticated Cross Site Scripting (XSS) in Fast Velocity Minify <= 3.5.7 versions. CWE-79
- CVE-2026-39739 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')… CWE-79