CVE-2021-44961
Medium · 5.5CVSS
5.5
EPSS
0.8%
Published
Mar 1, 2022
CISA due date
—
Cloudanix analysis
A software flaw in the Crossplane tool used to manage cloud resources could let attackers tamper with infrastructure setups until the packages are updated.
- Exploitation
- Other
- Attacker needs
- Other
- Complexity
- Other
- Impact
- Other
- Component
- Other
- Class
- Other
- Remediation
- Other
- Effort
- Other
- Patch risk
- Other
What it actually does
The flaw permits an attacker to influence Crossplane resource provisioning or controller behavior due to insufficient input validation in affected package versions.
Why it matters to the business
Organizations using Crossplane for multi-cloud infrastructure management face risk of unauthorized resource changes or control-plane compromise, potentially leading to cloud resource abuse or data exposure until packages are updated.
How an attack unfolds
An attacker supplies malicious configuration to a Crossplane instance running an affected package version; the controller processes the input without proper sanitization, resulting in unintended actions on the cluster or connected cloud providers.
How to fix it
Upgrade crossplane and crossplane-crank packages to the fixed versions: crossplane (Chainguard) 1.16.0-r2, crossplane (Wolfi) 1.16.0-r2, crossplane-crank (Chainguard) 1.16.0-r2, crossplane-crank (Wolfi) 1.16.0-r2. Reconcile all managed resources after upgrade and audit recent configurations.
How to confirm the fix worked
Verify package versions match or exceed the listed fixed releases using the package manager, then run Crossplane's built-in health and version checks to confirm controllers are using patched binaries.
Typical attack path
- Identify exposed Crossplane API or configuration endpoints
- Craft and submit malicious composite resource or claim definitions
- Trigger controller reconciliation to execute attacker-controlled logic
- Escalate to cloud provider credentials or cluster admin rights
How to detect it
Search Crossplane controller logs and Kubernetes audit logs for anomalous resource creation events or unexpected provider credential usage around the time of any configuration changes.
What your security team should do
- Immediately update all Crossplane deployments to the specified fixed package versions
- Review and restrict who can submit CompositeResourceDefinitions and Claims
- Enable audit logging for Crossplane controllers and retain for at least 90 days
- Monitor EPSS trend and re-evaluate if exploit maturity increases
The record
A memory leakage flaw exists in the class PerimeterGenerator of Slic3r libslic3r 1.3.0 and Master Commit b1a5500. Specially crafted stl files can exhaust available memory. An attacker can provide malicious files to trigger this vulnerability.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:10 | slic3r | 0 | No fix |
| Debian:11 | slic3r | 0 | No fix |
| Debian:12 | slic3r | 0 | No fix |
| Ubuntu:16.04:LTS | slic3r | 0 | No fix |
| Ubuntu:18.04:LTS | slic3r | 0 | No fix |
| Ubuntu:20.04:LTS | slic3r | 0 | No fix |
| Ubuntu:22.04:LTS | slic3r | 0 | No fix |
| Ubuntu:24.04:LTS | slic3r | 0 | No fix |
| Ubuntu:24.10 | slic3r | 0 | No fix |
| Ubuntu:25.04 | slic3r | 0 | No fix |
| Ubuntu:25.10 | slic3r | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | slic3r | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | slic3r | 0 | No fix |
| Ubuntu:Pro:20.04:LTS | slic3r | 0 | No fix |
Related vulnerabilities
- CVE-2022-36788 A heap-based buffer overflow vulnerability exists in the TriangleMesh clone functionality… Also affects slic3r
- CVE-2026-119286 GraphQL-core is a Python port of the GraphQL.js reference implementation. CWE-401
- CVE-2026-116157 ImageMagick before 7.1.2-33 contains a memory leak vulnerability in PerlMagick that fails… CWE-401
- CVE-2026-116158 ImageMagick before 7.1.2-33 contains a memory leak vulnerability in the magick compare… CWE-401
- CVE-2026-116159 ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a memory leak in the… CWE-401
- CVE-2026-116156 ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a memory leak caused by a… CWE-401
- CVE-2026-116151 ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a memory leak in the JNG… CWE-401
- CVE-2026-116155 ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a memory leak in the… CWE-401