CVE-2017-7087
High · 8.8CVSS
8.8
EPSS
1.6%
Published
Oct 23, 2017
CISA due date
—
Cloudanix analysis
A problem in web viewing software could let attackers take over a device or make it crash if someone visits a specially made website.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Low
- Impact
- Full Compromise
- Component
- Web Framework
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Medium
What it actually does
Memory corruption in WebKit allows remote attackers to execute arbitrary code or trigger denial of service via crafted web content.
Why it matters to the business
Older systems remain exposed to potential remote compromise or service disruption when users access malicious websites, though widespread exploitation is not observed.
How an attack unfolds
An attacker crafts a malicious website that triggers the WebKit memory corruption flaw; when a victim visits the site using an affected browser or application, the flaw is triggered leading to code execution or crash. No named threat actors or ransomware campaigns are associated with this issue.
How to fix it
Upgrade aws-flb-kinesis (Chainguard) to 1.10.2-r7, aws-flb-kinesis (Wolfi) to 1.10.2-r7, aws-flb-kinesis-compat (Chainguard) to 1.10.2-r7, and aws-flb-kinesis-compat (Wolfi) to 1.10.2-r7. Apply vendor updates for any dependent WebKit components.
How to confirm the fix worked
Verify installed package versions match the fixed releases listed above and confirm no vulnerable WebKit instances remain in the environment.
Typical attack path
- Craft malicious HTML/JavaScript content targeting WebKit
- Host or embed the payload on a website
- Lure victim to visit the site via phishing or compromised page
- Victim's browser renders the content triggering memory corruption
- Attacker gains arbitrary code execution or causes application crash
How to detect it
Search application and system logs for WebKit-related crashes or memory errors following web browsing activity; review process execution after visiting untrusted sites.
What your security team should do
- Prioritize updating the listed packages to the specified fixed versions
- Review browser and application update policies for any lingering legacy WebKit usage
- Monitor EPSS trends and KEV status for changes in exploitation likelihood
The record
An issue was discovered in certain Apple products. iOS before 11 is affected. Safari before 11 is affected. iCloud before 7.0 on Windows is affected. iTunes before 12.7 on Windows is affected. tvOS before 11 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:10 | webkit2gtk | 0 | 2.18.1-1 |
| Debian:11 | webkit2gtk | 0 | 2.18.1-1 |
| Debian:12 | webkit2gtk | 0 | 2.18.1-1 |
| Debian:13 | webkit2gtk | 0 | 2.18.1-1 |
| Mageia:6 | webkit2 | 0 | 2.18.3-1.mga6 |
| SUSE:Linux Enterprise Desktop 12 SP2 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Desktop 12 SP3 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Server 12 SP2 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Server 12 SP3 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP2 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Software Development Kit 12 SP2 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Software Development Kit 12 SP3 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Workstation Extension 12 SP2 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| SUSE:Linux Enterprise Workstation Extension 12 SP3 | webkit2gtk3 | 0 | 2.18.5-2.18.1 |
| Ubuntu:16.04:LTS | qtwebkit-opensource-src | 0 | No fix |
| Ubuntu:16.04:LTS | qtwebkit-source | 0 | No fix |
| Ubuntu:16.04:LTS | webkit2gtk | 0 | 2.18.0-0ubuntu0.16.04.2 |
| Ubuntu:16.04:LTS | webkitgtk | 0 | No fix |
| Ubuntu:18.04:LTS | qtwebkit-opensource-src | 0 | No fix |
| Ubuntu:18.04:LTS | qtwebkit-source | 0 | No fix |
| Ubuntu:18.04:LTS | webkit2gtk | 0 | 2.18.0-2 |
| Ubuntu:18.04:LTS | webkitgtk | 0 | No fix |
| Ubuntu:20.04:LTS | qtwebkit-opensource-src | 0 | No fix |
| Ubuntu:22.04:LTS | qtwebkit-opensource-src | 0 | No fix |
| Ubuntu:24.04:LTS | qtwebkit-opensource-src | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | qtwebkit-opensource-src | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | qtwebkit-source | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | webkitgtk | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | qtwebkit-opensource-src | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | qtwebkit-source | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | webkitgtk | 0 | No fix |
| Ubuntu:Pro:20.04:LTS | qtwebkit-opensource-src | 0 | No fix |
| Ubuntu:Pro:22.04:LTS | qtwebkit-opensource-src | 0 | No fix |
| Ubuntu:Pro:24.04:LTS | qtwebkit-opensource-src | 0 | No fix |
Related vulnerabilities
- CVE-2024-27834 The issue was addressed with improved checks. Also affects webkit2gtk
- CVE-2024-23280 An injection issue was addressed with improved validation. Also affects webkit2gtk
- CVE-2024-23284 A logic issue was addressed with improved state management. Also affects webkit2gtk
- CVE-2024-23263 A logic issue was addressed with improved validation. Also affects webkit2gtk
- CVE-2024-23254 The issue was addressed with improved UI handling. Also affects webkit2gtk
- CVE-2024-23213 The issue was addressed with improved memory handling. Also affects webkit2gtk
- CVE-2024-23222 A type confusion issue was addressed with improved checks. Also affects webkit2gtk
- CVE-2024-23206 An access issue was addressed with improved access restrictions. Also affects webkit2gtk