CVE-2016-6855
High · 7.5CVSS
7.5
EPSS
18.4%
Published
Sep 7, 2016
CISA due date
—
Cloudanix analysis
A flaw in a popular Linux image viewer can make the program crash when it tries to open certain image files that contain bad text data.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Application
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Invalid UTF-8 input to GMarkup triggers an out-of-bounds write in Eye of GNOME when paired with glib versions before 2.44.1, resulting in a crash.
Why it matters to the business
Users of older Linux distributions may experience sudden application crashes when opening image files that contain malformed metadata, interrupting normal workflows and requiring restarts or alternative viewers.
How an attack unfolds
An attacker crafts an image file containing invalid UTF-8 sequences in metadata, then delivers the file to a target user who opens it with the vulnerable Eye of GNOME viewer; the malformed data reaches GMarkup and triggers the out-of-bounds write that crashes the process.
How to fix it
Upgrade Eye of GNOME to version 3.18.3 or later and 3.20.4 or later, and ensure glib is at least 2.44.1; apply all available distribution security updates for fedoraproject fedora, opensuse leap, opensuse opensuse, canonical ubuntu linux, and gnome packages.
How to confirm the fix worked
Verify installed eog and glib package versions against the fixed releases; attempt to open a test file containing invalid UTF-8 metadata and confirm the application no longer crashes; review distribution changelogs for the CVE fix.
Typical attack path
- Attacker generates a malicious image file embedding invalid UTF-8 in metadata fields
- File is distributed via email, web download, or shared storage
- Victim opens the file using Eye of GNOME on an affected system with glib < 2.44.1
- GMarkup processing encounters the malformed UTF-8 and performs an out-of-bounds write
- Application crashes, achieving denial of service
How to detect it
Review application crash logs and core dumps for segmentation faults originating from eog or glib GMarkup processing; search system logs for repeated eog process terminations when opening image files.
What your security team should do
- Prioritize patching eog and glib on all affected endpoints within 30 days given the available public exploit
- Block or sanitize image files from untrusted sources in high-risk environments until patches are deployed
- Monitor vulnerability scanners for remaining instances of eog < 3.18.3 or glib < 2.44.1
The record
Eye of GNOME (aka eog) 3.16.5, 3.17.x, 3.18.x before 3.18.3, 3.19.x, and 3.20.x before 3.20.4, when used with glib before 2.44.1, allow remote attackers to cause a denial of service (out-of-bounds write and crash) via vectors involving passing invalid UTF-8 to GMarkup.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | eog | 0 | 3.20.4-1 |
| Debian:12 | eog | 0 | 3.20.4-1 |
| Debian:13 | eog | 0 | 3.20.4-1 |
| Debian:14 | eog | 0 | 3.20.4-1 |
| Debian:7 | eog | 0 | 3.4.2-1+build1+deb7u1 |
| Debian:8 | eog | 0 | 3.14.1-1+deb8u1 |
| Mageia:5 | eog | 0 | 3.14.3-1.2.mga5 |
| SUSE:Linux Enterprise Desktop 12 SP1 | eog | 0 | 3.10.2-2.3.1 |
| SUSE:Linux Enterprise Server 12 SP1 | eog | 0 | 3.10.2-2.3.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP1 | eog | 0 | 3.10.2-2.3.1 |
| SUSE:Linux Enterprise Software Development Kit 12 SP1 | eog | 0 | 3.10.2-2.3.1 |
| Ubuntu:14.04:LTS | eog | 0 | 3.10.2-0ubuntu5.2 |
| Ubuntu:16.04:LTS | eog | 0 | 3.18.2-1ubuntu2.1 |
| openSUSE:Tumbleweed | eog | 0 | 3.20.5-1.1 |
Related vulnerabilities
- CVE-2013-7447 Integer overflow in the gdk_cairo_set_source_pixbuf function in gdk/gdkcairo.c in GTK+… Also affects eog
- CVE-2026-111497 A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli… CWE-787
- CVE-2026-112397 Pillow is a Python imaging library. CWE-787
- CVE-2026-112059 libLAS through 1.8.1 contains a heap out-of-bounds write vulnerability in the point… CWE-787
- CVE-2026-89088 A flaw was found in parted. CWE-787
- CVE-2026-89085 A flaw was found in parted. CWE-787
- CVE-2026-85746 MariaDB server is a community developed fork of MySQL server. CWE-787
- CVE-2026-107815 MariaDB server is a community developed fork of MySQL server. CWE-787