Cloudanix VulnDB

CVE-2016-4855

Medium · 6.1

CVSS

6.1

EPSS

1.9%

Published

May 12, 2017

CISA due date

—

Cloudanix analysis

Schedule a fix SSVC: Track

A bug in a widely used database helper library lets attackers slip harmful code into web pages so it runs inside other people's browsers.

Exploitation
Requires User Interaction
Attacker needs
User Interaction
Complexity
Low
Impact
Data Tampering
Component
Library
Class
XSS
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Cross-site scripting in ADOdb prior to 5.20.6 permits remote injection of arbitrary web script or HTML via unspecified vectors, allowing execution of attacker-controlled code in victims' browsers.

Why it matters to the business

Attackers may steal session tokens, perform unauthorized actions on behalf of users, or deface application interfaces, increasing risk of data exposure and operational disruption in any product embedding the vulnerable library.

How an attack unfolds

An attacker identifies an input path reaching the vulnerable ADOdb code, supplies a crafted payload containing script tags or event handlers, and waits for a victim to load the resulting page so the injected code executes in the browser context.

How to fix it

Upgrade ADOdb to version 5.20.6 or newer; for cert-exporter-fips (Chainguard) update to 2.12.0-r8 or later to remove the vulnerable library version.

How to confirm the fix worked

Inventory all instances of ADOdb and confirm versions are 5.20.6 or higher; retest previously affected input vectors with known XSS payloads to verify sanitization.

Typical attack path

  1. Locate an entry point that passes unsanitized data to ADOdb rendering functions
  2. Inject malicious HTML or JavaScript payload through the identified vector
  3. Deliver the link or trigger to a target user
  4. Execute the script to exfiltrate cookies, tokens, or perform actions within the user's session

How to detect it

Examine web access logs and application responses for unexpected HTML tags, script elements, or event-handler attributes; correlate with user-reported browser warnings or anomalous session activity.

What your security team should do

  • Apply the listed fixed versions immediately due to the library's widespread use
  • Scan codebases and containers for any ADOdb release before 5.20.6
  • Add web application firewall rules that block common script injection patterns until patching is complete

The record

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected packages

Ecosystem Package Introduced Fixed
Packagist adodb/adodb-php 0 5.20.6
Debian:10 libphp-adodb 0 5.20.6-1
Debian:11 libphp-adodb 0 5.20.6-1
Debian:12 libphp-adodb 0 5.20.6-1
Debian:13 libphp-adodb 0 5.20.6-1
Debian:7 libphp-adodb 0 5.15-1+deb7u1
Mageia:5 php-adodb 0 5.18-5.1.mga5
Ubuntu:14.04:LTS libphp-adodb 0 5.15-1+deb7u1build0.14.04.1
Ubuntu:22.04:LTS libphp-adodb 0 5.20.19-1ubuntu0.1
Ubuntu:Pro:16.04:LTS libphp-adodb 0 5.20.3-1ubuntu1+esm1
Ubuntu:Pro:18.04:LTS libphp-adodb 0 5.20.9-1ubuntu0.1~esm1
Ubuntu:Pro:20.04:LTS libphp-adodb 0 5.20.16-1ubuntu0.1~esm1

Related vulnerabilities