CVE-2014-8143
NoneCVSS
—
EPSS
4.3%
Published
Jan 17, 2015
CISA due date
—
Cloudanix analysis
A configuration issue in Samba lets certain users give themselves extra network access rights they should not have, potentially allowing takeover of the entire directory service.
- Exploitation
- Remote Authenticated
- Attacker needs
- Low Privilege
- Complexity
- Moderate
- Impact
- Privilege Gain
- Component
- Application
- Class
- Privilege Escalation
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Allows remote authenticated users with delegated account creation rights to set the LDB userAccountControl UF_SERVER_TRUST_ACCOUNT bit on Samba AD DC, enabling elevation to domain controller privileges.
Why it matters to the business
Attackers can gain unauthorized control over the Active Directory domain, leading to full network compromise, data theft, and operational disruption; although published over a decade ago with low stable EPSS, unpatched instances remain high-risk in legacy environments.
How an attack unfolds
An attacker with limited delegation rights authenticates to a vulnerable Samba AD DC, creates or modifies an account, sets the server trust account bit, and assumes domain controller identity for further privilege escalation.
How to fix it
Upgrade Samba 4.0.x to 4.0.24 or newer, 4.1.x to 4.1.16 or newer, and 4.2.x to 4.2rc4 or newer; restrict delegation of authority for account creation where feasible.
How to confirm the fix worked
Confirm Samba version exceeds vulnerable ranges listed in the advisory; audit Active Directory for accounts with unexpected UF_SERVER_TRUST_ACCOUNT flags set by delegated users.
Typical attack path
- Obtain authenticated access with user or computer account delegation rights
- Leverage LDB interface to modify userAccountControl
- Set UF_SERVER_TRUST_ACCOUNT bit on a created or existing account
- Impersonate domain controller to escalate privileges across the domain
How to detect it
Examine Samba and Active Directory event logs for LDB modifications setting the UF_SERVER_TRUST_ACCOUNT bit; search for newly created accounts with server trust flags originating from delegated non-administrative users.
What your security team should do
- Apply the appropriate Samba upgrade immediately on all AD DC instances
- Review and minimize delegation permissions for account creation
- Implement monitoring for userAccountControl modifications
- Test domain controller functionality post-upgrade
The record
Samba 4.0.x before 4.0.24, 4.1.x before 4.1.16, and 4.2.x before 4.2rc4, when an Active Directory Domain Controller (AD DC) is configured, allows remote authenticated users to set the LDB userAccountControl UF_SERVER_TRUST_ACCOUNT bit, and consequently gain privileges, by leveraging delegation of authority for user-account or computer-account creation.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | samba | 0 | 2:4.1.17+dfsg-1 |
| Debian:12 | samba | 0 | 2:4.1.17+dfsg-1 |
| Debian:13 | samba | 0 | 2:4.1.17+dfsg-1 |
| Ubuntu:14.04:LTS | samba | 0 | 2:4.1.6+dfsg-1ubuntu2.14.04.4 |
| openSUSE:Tumbleweed | samba | 0 | 4.5.0-1.1 |
Related vulnerabilities
- CVE-2020-1472 An elevation of privilege vulnerability exists when an attacker establishes a vulnerable… Also affects samba
- CVE-2017-15275 Samba before 4.7.3 might allow remote attackers to obtain sensitive information by… Also affects samba
- CVE-2017-14746 Use-after-free vulnerability in Samba 4.x before 4.7.3 allows remote attackers to execute… Also affects samba
- CVE-2017-11103 Heimdal before 7.4 allows remote attackers to impersonate services with Orpheus' Lyre… Also affects samba
- CVE-2017-9461 smbd in Samba before 4.4.10 and 4.5.x before 4.5.6 has a denial of service vulnerability… Also affects samba
- CVE-2017-7494 Samba since version 3.5.0 and before 4.6.4, 4.5.10 and 4.4.14 is vulnerable to remote… Also affects samba
- CVE-2016-2119 libcli/smb/smbXcli_base.c in Samba 4.x before 4.2.14, 4.3.x before 4.3.11, and 4.4.x… Also affects samba
- CVE-2016-2115 Samba 3.x and 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 does not… Also affects samba