CVE-2013-7108
NoneCVSS
—
EPSS
61.6%
Published
Jan 15, 2014
CISA due date
—
Cloudanix analysis
A bug in older monitoring software lets logged-in users pull private data from memory or shut the system down.
- Exploitation
- Remote Authenticated
- Attacker needs
- Low Privilege
- Complexity
- Low
- Impact
- Data Exposure
- Component
- Application
- Class
- Improper Input Validation
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Multiple off-by-one errors in process_cgivars allow remote authenticated users to trigger heap-based buffer over-read via long strings in the final key value of CGI variable lists, resulting in sensitive memory disclosure or application crash.
Why it matters to the business
Attackers can extract sensitive process data or disrupt monitoring services, leading to operational downtime and potential loss of visibility into infrastructure health; the vulnerability affects widely deployed monitoring stacks with moderate exploitation likelihood per EPSS.
How an attack unfolds
An authenticated attacker submits a specially crafted HTTP request containing an overly long final key-value pair to any of the listed CGI scripts, causing the off-by-one error during variable list processing and enabling either memory leakage or denial of service.
How to fix it
Upgrade Nagios Core beyond 4.0.2 or Icinga to 1.8.5+, 1.9.4+, or 1.10.2+; for listed Tomcat (Bitnami) instances upgrade to 8.5.64.
How to confirm the fix worked
Confirm installed versions match or exceed the fixed releases; perform regression testing with long CGI variable payloads to verify absence of over-read behavior.
Typical attack path
- Obtain valid credentials for the monitoring web interface
- Target one of the vulnerable CGI endpoints in cgi/
- Append an excessively long string as the final key value in the variable list
- Trigger process_cgivars to induce buffer over-read and observe results or crash
How to detect it
Inspect web server logs for unusually long strings in requests to the listed CGI scripts; correlate with process crashes or memory-related errors in application logs.
What your security team should do
- Prioritize patching given available public exploits and stable EPSS score
- Restrict authenticated access to CGI endpoints where possible
- Review web access logs for anomalous long parameter values
The record
Multiple off-by-one errors in Nagios Core 3.5.1, 4.0.2, and earlier, and Icinga before 1.8.5, 1.9 before 1.9.4, and 1.10 before 1.10.2 allow remote authenticated users to obtain sensitive information from process memory or cause a denial of service (crash) via a long string in the last key value in the variable list to the process_cgivars function in (1) avail.c, (2) cmd.c, (3) config.c, (4) extinfo.c, (5) histogram.c, (6) notifications.c, (7) outages.c, (8) status.c, (9) statusmap.c, (10) summary.c, and (11) trends.c in cgi/, which triggers a heap-based buffer over-read.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:10 | icinga | 0 | 1.10.2-1 |
| Debian:6.0 | icinga | 0 | 1.0.2-2+squeeze2 |
| Debian:7 | icinga | 0 | 1.7.1-7 |
| Debian:8 | nagios3 | 0 | 3.5.1.dfsg-2+deb8u1 |
| Mageia:3 | nagios | 0 | 3.4.4-4.2.mga3 |
| Ubuntu:14.04:LTS | icinga | 0 | 1.10.2-1 |
| Ubuntu:14.04:LTS | nagios3 | 0 | 3.5.1-1ubuntu1.1 |
| Ubuntu:16.04:LTS | nagios3 | 0 | 3.5.1.dfsg-2.1ubuntu1.1 |
| openSUSE:Tumbleweed | nagios | 0 | 4.4.6-2.5 |
Related vulnerabilities
- CVE-2012-6096 Multiple stack-based buffer overflows in the get_history function in history.cgi in… Also affects icinga
- CVE-2011-2179 Multiple cross-site scripting (XSS) vulnerabilities in config.c in config.cgi in (1)… Also affects icinga
- CVE-2016-9565 MagpieRSS, as used in the front-end component in Nagios Core before 4.2.2 might allow… Also affects nagios3
- CVE-2022-38247 Nagios XI v5.8.6 was discovered to contain a cross-site scripting (XSS) vulnerability via… Also affects nagios3
- CVE-2022-38248 Nagios XI before v5.8.7 was discovered to contain multiple cross-site scripting (XSS)… Also affects nagios3
- CVE-2022-38249 Nagios XI v5.8.6 was discovered to contain a cross-site scripting (XSS) vulnerability via… Also affects nagios3
- CVE-2022-38250 Nagios XI v5.8.6 was discovered to contain a SQL injection vulnerability via the mib_name… Also affects nagios3
- CVE-2022-38254 Nagios XI before v5.8.7 was discovered to contain a cross-site scripting (XSS)… Also affects nagios3