CVE-2026-85247
Medium · 5.9CVSS
5.9
EPSS
0.5%
Published
Oct 19, 2026
CISA due date
—
The record
Improper Certificate Validation vulnerability in Apache Camel Knative component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. When SSL was enabled on the Knative HTTP client but no truststore was configured, the client options fell back to trusting every presented certificate rather than to the JVM's default trust anchors. A deployment that switched TLS on without also configuring a truststore therefore obtained an encrypted connection with no peer authentication, which an attacker positioned on the network path can terminate and read. The dangerous state is reached by omission rather than by an explicit opt-in, which is what makes it a framework defect: turning TLS on should not be the thing that turns certificate validation off. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. With no truststore configured the trust options are now left unset so the JVM default trust anchors apply, the same fallback SSLContextParameters and the rest of Camel use. Trusting every certificate is now reached only by asking for it explicitly through the trust.all property, which remains available for development against a cluster with a self-signed certificate. For deployments that cannot upgrade immediately, configure a truststore explicitly wherever SSL is enabled. After upgrading, a deployment that was relying on the implicit trust-all behaviour must either configure a truststore or set the trust.all property deliberately.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-121565 Tanium addressed an improper certificate validation vulnerability in multiple products. CWE-295
- CVE-2026-121624 Nanosystems Supremo for Windows and macOS before 5.0.2.3874 contains an improper… CWE-295
- CVE-2026-115714 Improper Certificate Validation (CWE-295) in the operating system certificate bundle… CWE-295
- CVE-2026-121452 bbs-go through 4.4.6 contains an improper certificate validation vulnerability that… CWE-295
- CVE-2026-121392 FreeRDP before 3.32.2 contains an improper certificate validation vulnerability in… CWE-295
- CVE-2026-91897 Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper… CWE-295
- CVE-2026-120250 OpenAlgo 1.0.0.29 before 2.0.3.1 contains an improper certificate validation… CWE-295
- CVE-2026-118147 Improper certificate validation in Visual Studio allows an unauthorized attacker to… CWE-295