CVE-2026-73626
High · 7.5CVSS
7.5
EPSS
0.4%
Published
Aug 13, 2026
CISA due date
—
The record
JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-114574 A security vulnerability has been detected in massCodeIO massCode 5.10. CWE-284
- CVE-2026-83395 Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise… CWE-284
- CVE-2026-112091 A flaw has been found in Dav-ee dairy-management-system… CWE-284
- CVE-2026-106580 ImageMagick is free and open-source software used for editing and manipulating digital… CWE-284
- CVE-2026-61700 MariaDB Connector/J is used to connect applications developed in Java to MariaDB and… CWE-284
- CVE-2026-86812 The WPCafe WordPress plugin before 3.0.18 does not correctly restrict access to a set of… CWE-284
- CVE-2026-85545 There is an Vulnerability in some HikCentral Access Control versions. CWE-284
- CVE-2026-78084 Joomla Extension - joomshaper.com - Missing Access Control in Gallery Image Management in… CWE-284