CVE-2026-54232
High · 8.8CVSS
8.8
EPSS
0.6%
Published
Jun 22, 2026
CISA due date
—
The record
vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-87530 Uncontrolled search path element in CredentialProvider in Google Chrome on on Windows… CWE-427
- CVE-2026-76199 Photoshop Desktop is affected by an Uncontrolled Search Path Element vulnerability that… CWE-427
- CVE-2026-45221 Konga before 2.1.0 contains a privilege escalation vulnerability that allows… CWE-427
- CVE-2026-19590 OpenAI Codex Desktop for Windows and macOS could execute attacker-controlled Git hooks… CWE-427
- CVE-2026-82649 SiYuan Windows installer before version 3.8.1 (affected versions >= 2.0.14) contains an… CWE-427
- CVE-2026-65093 NVIDIA OpenShell for Linux contains a vulnerability where an attacker could cause a… CWE-427
- CVE-2026-50773 An issue in CGM Germany - CompuGroup Medical CGM ISIS MED 2510.1.0.20 allows a remote… CWE-427
- CVE-2026-56090 Dell ObjectScale, versions prior to 4.3.0.1, contain(s) an Uncontrolled Search Path… CWE-427