CVE-2026-5130
High · 8.8CVSS
8.8
EPSS
0.6%
Published
Mar 30, 2026
CISA due date
—
The record
The Debugger & Troubleshooter plugin for WordPress was vulnerable to Unauthenticated Privilege Escalation in versions up to and including 1.3.2. This was due to the plugin accepting the wp_debug_troubleshoot_simulate_user cookie value directly as a user ID without any cryptographic validation or authorization checks. The cookie value was used to override the determine_current_user filter, which allowed unauthenticated attackers to impersonate any user by simply setting the cookie to their target user ID. This made it possible for unauthenticated attackers to gain administrator-level access and perform any privileged actions including creating new administrator accounts, modifying site content, installing plugins, or taking complete control of the WordPress site. The vulnerability was fixed in version 1.4.0 by implementing a cryptographic token-based validation system where only administrators can initiate user simulation, and the cookie contains a random 64-character token that must be validated against database-stored mappings rather than accepting arbitrary user IDs.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-111749 AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. CWE-565
- CVE-2026-75757 Reliance on Cookies without Validation and Integrity Checking vulnerability in… CWE-565
- CVE-2026-8337 Concrete CMS 9.5.0 and below is vulnerable to IDOR in surveys. To be vulnerable, a site… CWE-565
- CVE-2026-0257 Authentication bypass vulnerabilities in the GlobalProtect portal and gateway of Palo… CWE-565
- CVE-2026-39963 Serendipity is a PHP-powered weblog engine. CWE-565
- CVE-2026-39324 Rack::Session is a session management implementation for Rack. CWE-565
- CVE-2014-125112 Plack::Middleware::Session::Cookie versions through 0.21 for Perl allows remote code… CWE-565
- CVE-2022-50926 WAGO 750-8212 PFC200 G2 2ETH RS firmware contains a privilege escalation vulnerability… CWE-565