Cloudanix VulnDB

CVE-2026-49871

Critical · 9.3

CVSS

9.3

EPSS

0.4%

Published

Jun 19, 2026

CISA due date

—

The record

Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected packages

Ecosystem Package Introduced Fixed

Related vulnerabilities