CVE-2026-48850
Low · 3.7CVSS
3.7
EPSS
0.4%
Published
May 25, 2026
CISA due date
—
Cloudanix analysis
Older versions of a common remote-access tool can crash when connecting to a specially behaving server, potentially disrupting administrative work.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- High
- Impact
- Denial Of Service
- Component
- Application
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
PuTTY versions 0.72 through versions before 0.84 contain a double-free memory management flaw in the RSA key exchange implementation. During SSH connection negotiation, a malformed or unusual RSA key exchange sequence can cause PuTTY to free the same memory object more than once, leading to process instability and likely client crash. Based on the provided CVSS vector, the expected impact is limited to availability of the PuTTY client process, with no confirmed confidentiality or integrity impact and no known public exploit maturity.
Why it matters to the business
Successful exploitation can interrupt SSH sessions by crashing the PuTTY client, potentially disrupting administrators, support staff, automation operators, or users who rely on PuTTY for remote access. The business risk is generally low because exploitation is rated high-complexity, there is no known exploitation, EPSS is low, and the flaw is not listed in CISA KEV; however, organizations with broad PuTTY deployment should still upgrade because SSH clients are commonly used for privileged administrative access.
How an attack unfolds
An attacker would need to position a malicious or attacker-controlled SSH server, or otherwise influence a user or automated workflow to connect to such a server using an affected PuTTY version. During SSH handshake negotiation, the server would steer the session into RSA key exchange behavior that triggers the double-free condition in vulnerable PuTTY builds. If successful, the PuTTY process may terminate unexpectedly, disconnecting the session. The provided scoring indicates exploitation requires high complexity and does not provide direct code execution, credential theft, or data modification based on currently available information.
How to fix it
Upgrade PuTTY to version 0.84 or later across all systems where PuTTY is installed or packaged. If immediate upgrade is not possible, reduce exposure by avoiding connections to untrusted SSH servers, using alternative patched SSH clients for high-risk workflows, and limiting administrative SSH access to known, trusted hosts. Because no exact fixed package versions were provided beyond the upstream version boundary, use vendor or distribution advisories to identify the corrected package for each platform and verify that packaged PuTTY builds correspond to upstream 0.84 or later.
How to confirm the fix worked
Confirm installed PuTTY versions are 0.84 or later by checking the application About dialog, executable metadata, package manager inventory, software asset management tools, or endpoint management records. Validate that older standalone copies of putty.exe, pageant.exe, plink.exe, pscp.exe, and psftp.exe are not left in user profile directories, shared tool folders, scripts, or portable software locations. Where patch validation testing is required, confirm that connections to trusted SSH servers complete normally after upgrade and that vulnerable versions are no longer present in software inventory scans.
Typical attack path
- Identify users or workflows that use PuTTY versions 0.72 through before 0.84 to initiate SSH sessions.
- Operate or compromise an SSH server that the victim may connect to, or otherwise induce connection to an attacker-controlled endpoint.
- Negotiate RSA key exchange parameters crafted to trigger the vulnerable memory handling path.
- Trigger the double-free condition during SSH key exchange.
- Cause the PuTTY client process to crash or terminate, disrupting the SSH session.
How to detect it
To assess possible prior exploitation, review endpoint crash telemetry, Windows Event Logs, EDR process events, and application reliability records for PuTTY-family processes terminating unexpectedly during or immediately after outbound SSH connections. Correlate crashes of putty.exe, plink.exe, pscp.exe, or psftp.exe with network logs showing TCP connections to port 22 or other SSH service ports, especially to unfamiliar external hosts. Investigate repeated crashes tied to the same remote SSH endpoint, newly contacted servers, or sessions where host key prompts or key exchange failures occurred. Because the known impact is availability and no specific public exploit artifacts are provided, detection should focus on crash patterns, anomalous SSH destinations, and use of vulnerable PuTTY versions rather than durable host indicators.
- putty.exe
- plink.exe
- pscp.exe
- psftp.exe
- Application Error
- Faulting application name: putty.exe
- Faulting application name: plink.exe
- Faulting application name: pscp.exe
- Faulting application name: psftp.exe
- Windows Error Reporting
- PuTTY Fatal Error
- TCP/22
What your security team should do
- Inventory PuTTY installations and prioritize upgrade of versions 0.72 through before 0.84, especially on administrator workstations and jump-host workflows.
- Deploy PuTTY 0.84 or later from trusted vendor sources and remove older portable binaries from user-writeable folders and shared tool repositories.
- Monitor for repeated PuTTY crashes during SSH connection negotiation, especially when associated with connections to unfamiliar or newly observed SSH servers.
- Restrict administrative SSH workflows to trusted server inventories and discourage users from connecting PuTTY to unverified hosts.
- Because this issue is not in CISA KEV, has low EPSS, and has no known exploit maturity, handle through standard patch cadence unless PuTTY is widely deployed in privileged operational workflows.
The record
PuTTY 0.72 before 0.84 has a double free in RSA KEX.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-109271 ImageMagick 7.1.2-30 before 7.1.2-32 contains a use after free vulnerability in the… CWE-415
- CVE-2026-107886 OpenPrinting CUPS before 2.4.20 contains a double-free in printer-class management. CWE-415
- CVE-2026-107209 ImageMagick is free and open-source software used for editing and manipulating digital… CWE-415
- CVE-2026-98154 In the Linux kernel, the following vulnerability has been resolved: nvme-rdma: fix -EIO… CWE-415
- CVE-2026-87585 Double free in PDFium in Google Chrome on on Windows prior to 153.0.8010.36 allowed a… CWE-415
- CVE-2026-79907 Acrobat Reader is affected by a Double Free vulnerability that could result in arbitrary… CWE-415
- CVE-2026-82325 A use-after-free vulnerability in the OpenVPN ovpn-dco-win driver version 2.5.0 through… CWE-415
- CVE-2026-20510 In camera middleware, there is a possible escalation of privilege due to double free. CWE-415