CVE-2026-48817
Medium · 5.3CVSS
5.3
EPSS
0.3%
Published
Jun 17, 2026
CISA due date
—
The record
Starlette is a lightweight ASGI framework/toolkit. In versions 1.0.1 and below, when dispatching a request, HTTPEndpoint selects the handler by lowercasing the HTTP method and looking it up as an attribute with getattr, without restricting the lookup to a known set of HTTP verbs. When an HTTPEndpoint subclass is registered through Route(...) without an explicit methods= argument, the route does not constrain the method and every method reaches the endpoint. If a non-standard HTTP method whose lowercased name matches an attribute on the endpoint subclass reaches the endpoint, that attribute is invoked as if it were a request handler. An attacker can use this to reach methods that were never meant to be HTTP handlers, such as internal helpers, without the authorization checks applied by the intended public handler. An application (including Starlette-based frameworks like FastAPI) is affected if it registers an HTTPEndpoint subclass via Route(...) without explicitly setting methods=, and that subclass includes extra methods named like non-standard HTTP verbs that take one request argument and return a response. This issue has been fixed in version 1.1.0.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| openSUSE:Leap 16.0 | python-starlette | 0 | 0.41.3-160000.4.1 |
Related vulnerabilities
- CVE-2026-54282 Starlette is a lightweight ASGI framework/toolkit. Also affects python-starlette
- CVE-2026-54283 Starlette is a lightweight ASGI framework/toolkit. Also affects python-starlette
- CVE-2026-48710 Starlette is a lightweight ASGI framework/toolkit. Also affects python-starlette
- CVE-2025-62727 Starlette is a lightweight ASGI framework/toolkit. Also affects python-starlette
- CVE-2025-54121 Starlette is a lightweight ASGI (Asynchronous Server Gateway Interface)… Also affects python-starlette
- CVE-2026-114660 Grav from 2.0.0 before 2.2.5 contains an improper access control vulnerability in… CWE-470
- CVE-2026-112145 A security vulnerability has been detected in speaches-ai speaches up to 0.9.0-rc.3. CWE-470
- CVE-2026-78030 DBI versions before 1.653 for Perl load arbitrary modules via unvalidated dbm_type and… CWE-470